Bug 5786 - can not upgrade a red hat on software raid device
can not upgrade a red hat on software raid device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 15:44 EDT by hannu.laurila
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-22 14:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hannu.laurila 1999-10-09 15:44:08 EDT
We have a Red Hat 6.0 system (installed with a customized
red hat 6.0 installer) which has been installed on
Linux RAID1 partitions. The box has the following
partitions:

/dev/md0: root filesystem consisting of sda1 and sdb1
/dev/md1: swap partition consisting of sda2 and sdb2

Raid version is Linux 2.2.10+RAID 19990724. RAID partitions
have persistent superblock (autodetectable, 0xfd).

We boot the system up always from a diskette (diskette has
2.2.10+RAID19990724-kernel with rdev /dev/md0).

Now we are about to upgrade this test system to Red Hat 6.1.
This message is to report you about some problems which
we ran to when trying to upgrade the system described above:

Problem #1:

BOOT kernel (on the installation diskette) does not have
RAID autodetection enabled. I think it makes sense to
enable autodetection. I am not sure that it helps - I am
not sure if Linux kernel runs autodetection again after
the red hat installer has loaded appropriate SCSI modules.

Well, I could work around this problem by putting my
own custom kernel to the boot diskette. The custom kernel
has autodetection, raid1 and scsi driver (to make things
sure) all statically linked in.

Problem #2:

Red Hat installer does not find existing installation
on md0. It seems that it only tries to find the existing
installation from sda, sdb, ... devices.


So, by fixing the problem number #2 you could make
upgrading a raid system relatively easy! (at maximum, user
would have to supply a custom kernel to boot diskette)

And fixing problem #1 (if it gets fixed only by enabling one
autodetect-option) would not increase kernel size
dramatically so it would still fit on the boot diskette ;)
Comment 1 Jay Turner 1999-10-22 14:46:59 EDT
*** This bug has been marked as a duplicate of 5607 ***

Note You need to log in before you can comment on or make changes to this bug.