Bug 5787 - Wrong protocol for MS Intellimouse PS/2 in XF86Config
Wrong protocol for MS Intellimouse PS/2 in XF86Config
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
: 4984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 15:46 EDT by jukka.laurila
Modified: 2015-01-07 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 11:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jukka.laurila 1999-10-09 15:46:17 EDT
I installed RH 6.1 on a computer with a Microsoft
Intellimouse PS/2, so naturally I selected that as the mouse
type when prompted. The mouse worked fine during the
install, but didn't work in X when the system booted. I got
the mouse working by changing the line
	Protocol "PS/2"
to
	Protocol "IMPS/2"
in /etc/X11/XF86Config. In addition, I suggest that the
installer should add the line
	ZAxisMapping 4 5
to the Pointer section of XF86Config for wheel mice, since
that line alone is enough to make the wheel work in all GTK
applications.
Comment 1 wpb-rhl 1999-10-19 11:40:59 EDT
Similar Problem: Microsoft IntelliMouse 1.1A PS/2 was dectected by the
installer as a Generic 3 button.  Changed this to MS IntelliMouse and
installation went fine, however, once completed and booting into
gnome, the mouse pointer jumped to the top right corner of the screen
and couldn't be moved.  Running mouseconfig and selecting Microsoft
IntelliMouse (PS/2) [*] Emulate 3 Buttons updated the XFree86 config
file and the next time gnome started the mouse functioned as expected.
 --wpb
Comment 2 Jay Turner 1999-10-21 15:51:59 EDT
*** Bug 6154 has been marked as a duplicate of this bug. ***

The installer sets the X mouse protocol to PS/2 for an
MS intellimouse. It should set it to IMPS/2 otherwise
X doesnt work (mouse jumps wildly)
Comment 3 Jay Turner 1999-11-02 11:06:59 EST
*** Bug 6629 has been marked as a duplicate of this bug. ***

During the Mouse Configuration step, I configured my mouse
as a Microsoft Intellimouse (PS/2).  When the system was
first brought up into run level 5, there was no mouse point.

I had to drop the system into run level 3, edit the
/etc/X11/XF86Config file and change the protocol from "PS/2"
to "imps/2".  Then the mouse worked.
Comment 4 Jay Turner 1999-12-06 11:12:59 EST
*** Bug 4984 has been marked as a duplicate of this bug. ***
Comment 5 Brian Ryner 2000-01-07 22:19:59 EST
The installer also needs to set the mouse protocol correctly for other mouse
types, for example "MouseManPlusPS/2" for some Logitech mice.  Mouseconfig can
set this correctly, and since the installer asks for your specific mouse type it
should be fairly simple to make it set the protocol correctly in XF86Config.

On a related note, it would be very nice if the installer could add the line:

ZAxisMapping 4 5

if you select a mouse that has a wheel.
Comment 6 Jay Turner 2000-02-08 11:18:59 EST
This is fixed in the latest installer code.  Try grabbing the latest RawHide.

Note You need to log in before you can comment on or make changes to this bug.