This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 578706 - Publican adds extra hyphens to screen examples
Publican adds extra hyphens to screen examples
Status: CLOSED DUPLICATE of bug 577068
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-01 01:55 EDT by David Jorm
Modified: 2014-10-20 20:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-05 21:15:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jorm 2010-04-01 01:55:04 EDT
Description of problem:
Publican adds additional hyphens to screen examples. This only occurs for PDF rendering and does not occur for version 1.6.0.

Version-Release number of selected component (if applicable):
1.6.2

How reproducible:


Steps to Reproduce:
1. Build a book using the snippet:

<screen>$ grep -E &#39;svm|vmx&#39; /proc/cpuinfo</screen>

2. The rendered PDF will show:
$ grep ­­--E ­-'svm|vmx' ­-/proc/cpuinfo
3. The rendered HTML is fine
Comment 1 Ruediger Landmann 2010-04-01 02:11:37 EDT
Confirmed that this is indeed a hyphenation issue:

when 

<xsl:-Param name="hyphenate.verbatim" select="0"/> 

in the pdf.xsl is changed to "1", the extra hyphen goes away, as with BZ 577068
Comment 2 Ruediger Landmann 2010-04-01 02:54:48 EDT
(In reply to comment #1)
> Confirmed that this is indeed a hyphenation issue:
> 
> when 
> 
> <xsl:-Param name="hyphenate.verbatim" select="0"/> 
> 
> in the pdf.xsl is changed to "1", the extra hyphen goes away, as with BZ 577068    

D'oh -- other way around, of course :)
Comment 3 Jeff Fearn 2010-04-05 21:15:05 EDT

*** This bug has been marked as a duplicate of bug 577068 ***

Note You need to log in before you can comment on or make changes to this bug.