This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 578712 - Some hotkeys on Samsung N140 doesn't work
Some hotkeys on Samsung N140 doesn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-01 02:42 EDT by Robin Sonefors
Modified: 2010-04-13 12:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 12:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/lib/udev/keymap input/event5 > keymap.txt (7.06 KB, text/plain)
2010-04-01 02:42 EDT, Robin Sonefors
no flags Details

  None (edit)
Description Robin Sonefors 2010-04-01 02:42:02 EDT
Created attachment 403895 [details]
/lib/udev/keymap input/event5 > keymap.txt

I marked this Fedora 13, but it was broken as well in Fedora 12.

As the subject says, I have a Samsung N140, and only some of it's hotkeys works.

The keyboard is known as /dev/input/event5. I have tried executing /lib/udev/keymap -i input/event5, and it doesn't react when I press the broken hotkeys. I tried lshal -m with identical results.

I also tried to use the tool getscancodes, which can be downloaded from http://keytouch.sourceforge.net/dl-getscancodes.html and has really short source code. Executing getscancodes /dev/input/event5 does print the scancodes of the broken hotkeys, but for all working keys it prints them both on keypress and keyrelease, but the broken keys are only printed on kepress.

When I read /usr/share/doc/udev-151/README.keymap.txt, I saw that it suggested that I add the keycodes to a file in /lib/udev/keymaps, however, the broken hotkeys are already listed in /lib/udev/keymaps/samsung-other. It also suggests that if there is no keyrelease event, it can be added to /lib/udev/keymaps/95-keyboard-force-release-rules. I don't have a file like that, but I do have a /lib/udev/keymaps/force-release folder, and in it, the file samsung-other lists the broken hotkeys.

Surprisingly (to me, at least), the touchpad on/off hotkey, which is listed in the samsung-other files, actually work, while none of the others do.

I'm attaching the output of /lib/udev/keymap input/event5. If I understand this correctly, for instance 0x088/0x089 should not say reserved, but rather brightnessup/brightnessdown.
Comment 1 Harald Hoyer 2010-04-01 04:18:46 EDT
(In reply to comment #0)
> When I read /usr/share/doc/udev-151/README.keymap.txt, I saw that it suggested
> that I add the keycodes to a file in /lib/udev/keymaps, however, the broken
> hotkeys are already listed in /lib/udev/keymaps/samsung-other. 

README.keymap.txt also says:

 6. Send the system vendor/product names, the key mapping from step 3,
 /tmp/orig-map.txt from step 2, and /tmp/udev-db.txt from step 5
 to the bug tracker, so that they can be included in the next release:

   https://bugs.launchpad.net/udev-extras/+bugs


So, please take the short circuit and let the author of "keymap" know about your findings. I could copy&paste back and forth between these two bug tracking web sites for you, but I think it's easier, if you file your findings directly.

Note You need to log in before you can comment on or make changes to this bug.