Bug 578734 - Time sync issues on RHEL4.8 and RHEL 5.4 guests
Time sync issues on RHEL4.8 and RHEL 5.4 guests
Status: CLOSED DUPLICATE of bug 531701
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity urgent
: rc
: ---
Assigned To: Glauber Costa
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-04-01 04:17 EDT by Dan Yasny
Modified: 2013-07-02 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-25 09:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Yasny 2010-04-01 04:17:38 EDT
Description of problem:
We've been using RHEL4.8 (2.6.9-89.ELsmp) KVM guests for a bit, and moved over several more from Xen to KVM last week (our buildfarm guests).  All of our RHEL4.8 guests have been reporting this for some time:

Same confirmed using RHEL5.4 guests.

warning: many lost ticks.
Your time source seems to be instable or some driver is hogging interupts
rip __do_softirq+0x4d/0xd0

However this hadn't been impacting us.  On our buildfarm systems, however, clock drift is a problem for the RHEL4 64-bit guests (not for RHEL3 32-bit and 64-bit guests using virtio drivers).


Version-Release number of selected component (if applicable):
kmod-kvm-83-105.el5_4.19.x86_64.rpm	
kvm-83-105.el5_4.19.x86_64.rpm	rpm	
kvm-debuginfo-83-105.el5_4.19.x86_64.rpm	
kvm-qemu-img-83-105.el5_4.19.x86_64.rpm	rpm	
kvm-tools-83-105.el5_4.19.x86_64.rpm	rpm	

How reproducible:
always

Steps to Reproduce:
Monitor clock with ntptime, here's sample output:

[root@bf10 ~]$ ntptime
ntp_gettime() returns code 5 (ERROR)
 time ced1122e.dffe4000  Mon, Dec 14 2009 11:36:14.874, (.874973),
 maximum error 16384000 us, estimated error 16384000 us
ntp_adjtime() returns code 5 (ERROR)
 modes 0x0 (),
 offset 0.000 us, frequency 0.000 ppm, interval 4 s,
 maximum error 16384000 us, estimated error 16384000 us,
 status 0x41 (PLL,UNSYNC),
 time constant 0, precision 1.000 us, tolerance 512 ppm,
 pps frequency 0.000 ppm, stability 512.000 ppm, jitter 200.000 us,
 intervals 0, jitter exceeded 0, stability exceeded 0, errors 0.
  
Actual results:
During migration between different hosts, the time sync fails

Expected results:
No time sync issues.

Additional info:
Comment 4 Dan Yasny 2010-04-07 08:10:26 EDT
I'll find out the cmd line. The kernel options used are as described in http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.4/html/Virtualization_Guide/chap-Virtualization-KVM_guest_timing_management.html
Comment 7 Zachary Amsden 2010-06-22 16:55:29 EDT
Change bug title to make more sense; this has nothing to do with migration between hosts with different CPU speeds.
Comment 15 Glauber Costa 2010-10-07 09:34:02 EDT
Sorry,

What exactly do you mean by relative package?
Comment 20 Glauber Costa 2010-10-25 09:42:08 EDT

*** This bug has been marked as a duplicate of bug 531701 ***

Note You need to log in before you can comment on or make changes to this bug.