Bug 5788 - Cannot upgrade if existing /tmp dir is a symlink
Cannot upgrade if existing /tmp dir is a symlink
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-09 16:17 EDT by mattw
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-10-22 14:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mattw 1999-10-09 16:17:55 EDT
My /tmp dir is a symlink to /var/tmp (space reasons) and the
installer does not correctly handle the situation.  It gets
an exception error because it cannot open the
tmp/upgrade.log file for writing.  The problem can be solved
by removing the symlink and recreating the directory with
1777 permissions.

Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376, in
line 16, in run
line 1465, in doInstall
    self.instLog = open(self.instPath + logname, "w+")
IOError: [Errno 2] No such file or directory:
Comment 1 alanrb 1999-10-17 00:35:59 EDT
I ran into a similar problem, see bug 6014, with a link for
/etc/lilo.conf to /boot/lilo.conf. I fixed it by making the link
relative, ../boot/lilo.conf, which allowed the installers remounting
of the filesystems to not break the link.

Comment 2 Jay Turner 1999-10-21 12:23:59 EDT
*** Bug 6014 has been marked as a duplicate of this bug. ***

While upgrading from 6.0 to 6.1 via FTP I had several errors
that the installer did not handle very well. It apparently
just crashed the script and displayed a traceback. It took
me awhile before I figured out how to deal with this.
Clicking OK or DEBUG just seemed to eventually get me to a
hung system. Scrolling the traceback and trying to interpret
the messages eventually allowed me to get past the problems,
which I have listed below:

* /etc/lilo.conf was linked to /boot/lilo.conf on my 6.0
system, but that is not valid with the installs mounting
setup, so no writtable file existed. The lack of checking on
this may be related to the other problems with lilo.conf
that have been reported.

* Upgrade was done via FTP; transmission errors and login
failure due to exceeding user limits lead to script crash
and the traceback.

This may be tough to deal with, but I think a complete
novice user would be stuck if they hit these.
Comment 3 Jay Turner 1999-10-22 14:48:59 EDT
For the installer to be able to follow a symlink, it must be a
relative link and not an absolute

Note You need to log in before you can comment on or make changes to this bug.