Bug 57883 - Hangs X when running "penetrate" module
Hangs X when running "penetrate" module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-30 15:46 EST by Davide Bolcioni
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 17:29:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2001-12-30 15:46:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Picking "penetrate" for a demo in xscreensaver-demo freezes X solid on the
picture showing the "score" (text is badly garbled). The same
freezes occur when random selection of screen savers stumbles over the
penetrate module.

Version-Release number of selected component (if applicable): 3.33-4


How reproducible:
Always

Steps to Reproduce:
1. startx -- -dpi 100x100
2. run xscreensaver-demo from a terminal window
3. pick "Penetrate"
4. click "Demo"
	

Actual Results:  The demo runs until castles are destroyed, displays the
closing screen with garbled "high score" and freezes X solid. No VC
switching, no
Ctrl-Alt-Backspace. Could not try telnet, not on a LAN. Did not try SysRq,
not enabled.

Expected Results:  Should close and return to the desktop.

Additional info:

Note that startx is launched at 100x100 dpi; I have not tested if this
makes a difference. The host is a Athlon 700 with a Matrox G400 32MB.

This bug is similar to a number of other bugs, including
<a href="show_bug.cgi?id=56465">56465</a>, possibly <a
href="show_bug.cgi?id=57257">57257</a>, <a
href="show_bug.cgi?id=57090>57090</a>, <a
href="show_bug.cgi?id=55991">55991</a>, possibly <a
href="show_bug.cgi?id=54714">54714</a> on Alpha, <a
href="show_bug.cgi?id=54275">54275</a>, <a
href="show_bug.cgi?id=49586">49586</a>, <a
href="show_bug.cgi?id=42231">42231</a>, <a
href="show_bug.cgi?id=23659">23659</a> and some older others which I skip
because of their age.
Comment 1 Bill Nottingham 2002-01-24 02:23:10 EST
If the X server hangs, that indicates an X server bug.
Comment 2 Davide Bolcioni 2002-01-25 15:54:17 EST
Hmmm ... does the above imply that I should close this bug and open a new one ?

In any case, I can provide some extra information:
- booting with "mem=nopentium" (my system is Athlon + AGP) makes no difference;
- at 75x75 dpi "penetrate" runs flawlessly;
- at 100x100 dpi "penetrate" does not *always* hang ... only when I have some
  "castle" left (at 75 dpi, this writes "Level 1 Cleared" ... at 100 dpi, the
  letters are garbage) - if all castles are destroyed, I see "Game Over" at
  both resolutions.
Comment 3 Davide Bolcioni 2002-08-23 17:28:59 EDT
The upgrade to RedHat 7.3 apparently fixed this (XFree86-4.2.0-8,
xscreensaver-3.33-4). Works fine at 100 dpi now.
Comment 4 Mike A. Harris 2002-09-12 00:36:40 EDT
Thanks very much for the update.  Closing bug as fixed in CURRENTRELEASE
of Red Hat Linux 7.3.

Take care.

Note You need to log in before you can comment on or make changes to this bug.