Bug 578873 - Update license tag to BSD
Update license tag to BSD
Status: CLOSED DUPLICATE of bug 234191
Product: Fedora
Classification: Fedora
Component: arpack (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2010-04-01 12:08 EDT by Matt McCutchen
Modified: 2010-04-08 15:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-08 15:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt McCutchen 2010-04-01 12:08:30 EDT
Description of problem:
Octave, which is licensed under GPLv3+, links with arpack, which is licensed under RiceBSD, which was determined in bug 234191 to be GPL-incompatible.  This is not allowed under the FSF's interpretation that linking creates a derivative work, which Fedora is using.  (I'm pursing this in an effort to help Fedora comply with its own policies, without implying that I think the FSF is right.)

Version-Release number of selected component (if applicable):
octave-3.2.3-4.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpm -qf $(ldd /usr/libexec/octave/3.2.3/oct/x86_64-redhat-linux-gnu/eig.oct \
        | grep arpack | awk '{ print $3 }') --qf '%{LICENSE}\n'
Comment 1 Matt McCutchen 2010-04-01 16:38:55 EDT
David Bateman pointed out in bug 234191 comment 11 that the arpack license has changed to BSD.  So there is no incompatibility; instead, the arpack license tag just needs to be updated in Fedora.
Comment 2 Axel Thimm 2010-04-07 13:07:13 EDT

*** This bug has been marked as a duplicate of bug 234191 ***
Comment 3 Matt McCutchen 2010-04-07 13:14:32 EDT
If you want to dup this to bug 234191, then bug 234191 needs to be reopened and morphed to request the updating of the license tag in Fedora.
Comment 4 Axel Thimm 2010-04-07 14:13:45 EDT
Please check on the bug's status first, there are even builds underway.

*** This bug has been marked as a duplicate of bug 234191 ***
Comment 5 Matt McCutchen 2010-04-07 14:21:11 EDT
Bug 234191's status is CLOSED UPSTREAM.  As I said, it needs to be reopened before marking this one as a duplicate.  I would do that, but I don't have editbugs.
Comment 6 Alex Lancaster 2010-04-08 15:41:41 EDT
(In reply to comment #5)
> Bug 234191's status is CLOSED UPSTREAM.  As I said, it needs to be reopened
> before marking this one as a duplicate.  I would do that, but I don't have
> editbugs.    

Fixing this as a dupe, and will re-open the other.

*** This bug has been marked as a duplicate of bug 234191 ***

Note You need to log in before you can comment on or make changes to this bug.