Bug 57888 - keymap us-latin1 incomplete
keymap us-latin1 incomplete
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-30 19:41 EST by Josi Romildo Malaquias
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 16:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josi Romildo Malaquias 2001-12-30 19:41:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
The console keymap us-latin1 does not behave as an US-International
keyboard (a la Windows) as advertised in the keymap file. Some combinations
of dead keys with another key does not work, while they should. For
instance, to get a g (c-cedilla), one is expected to type the key '
(dead-acute) immediately followed by the key c in an US-Internationl
keymap. The us-latin1 just gives a single quote followed by a c. Another
example: ` (dead-grave) followed by a does not give ` (a-grave), but the
backquote character ` followed by the a vogal. The problem does not happen
with the XFree86 keyboard configured with the us-intl layout.

The US-International keymap is too common in Brazil, as it allows the input
of all accented letters plus the c-cedilla of the Portuguese language using
a standard US keyboard. Many users (like me) are already used to it and
prefer it to the national keyboard layout, ABNT2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login at the console (text mode).
2. Setup keyboard map the us-latin1 keymap, if not already done.
3. Type some text using dead-keys combined with vowels and the letter c.
For instance, type the keys 'a'e'i'o'u`a`e`i`o`u^a^e^i^o^u~a~o"a"e"i"o"u'c
	

Actual Results:  aimsz`a`e`i`o`u^a^e^i^o^u~a~o"a"e"i"o"u'c


Expected Results:  aimsz`hlrybjnt{cudkov|g

Note that only the dead-acute key is producing the expected result.

Additional info:

Conectiva distributes a good US-International keymap called us-acentos,
under the GNU GPL version 2, that is far better than the us-latin1 keymap
distributed by RedHat. I suggest that RedHat starts including it also. It
can be found inside the SRPM package at
ftp://ftp.conectiva.com.br/pub/conectiva/snapshot/SRPMS/console-tools-0.3.3-4cl.src.rpm.
Comment 1 Josi Romildo Malaquias 2001-12-30 19:46:08 EST
I would like to add that, because of this problem, after all RedHat Linux
instalation, I have to copy the us-acentos.kmap.gz file taken from the Conectiva
Linux distribution and install it at /lib/kbd/keymaps/i386/qwerty/ and than
setup the console keyboard map using the setup tool. This gets annoying and
RedHat could take care of it for us.
Comment 2 Eido Inoue 2004-08-23 16:40:21 EDT
After the switch to utf-8, we currently don't support multibyte
diacritics on the console.

Note You need to log in before you can comment on or make changes to this bug.