Bug 57890 - "alias usb-controller ???" not added to /etc/modules.conf
Summary: "alias usb-controller ???" not added to /etc/modules.conf
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-31 01:40 UTC by Eric Harrison
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 23:24:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Harrison 2001-12-31 01:40:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
The installer does not add "alias usb-controller usb-uhci" to
/etc/moudules.conf. After install, hotplug does not load the USB modules,
causing USB mice/keyboards to fail. USB keyboard/mouse works during install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH72 with USB keyboard/mouse (tested on Intel CA810E and MO810E
motherboards)

	

Actual Results:  USB modules not loaded, USB devices fail

Expected Results:  USB modules load, USB devices work

Additional info:

Repeatable on Intel CA810E motherboard with Intel 82801AA (rev 2) USB
controller and Intel MO810E motherboard

Comment 1 Peter Surda 2002-01-08 18:27:45 UTC
same here. I have a USB mouse and the alias line wasn't added into 
modules.conf at install time (though during the install the USB mouse worked, at 
least I think, I have a PS/2 touchpad and a USB mouse). After I added it, 
everything worked fine.


Comment 2 Seth Vidal 2002-01-13 19:36:36 UTC
ditto here. I can reproduce it on about 50-70 machines anytime you'd like to see it.



Comment 3 Michael Fulbright 2002-01-15 21:13:10 UTC
This should be handled by kudzu in the post-install.

Comment 4 Seth Vidal 2002-01-15 21:29:21 UTC
the problem is this.

when the system boots the first time after the install kudzu runs and says
"you've  removed your usb-mouse" or whatever.

I've booted it into single user mode before in this situation and looked at
/etc/modules.conf and alias usb-controller usb-uchi is not in there.

so I figured it was anaconda not kudzu.

but whatever its still not working right :)

thanks


Comment 5 Pavel Roskin 2002-12-17 21:56:09 UTC
I can reproduce this on Red Hat 8.0 (install over FTP). The USB mouse works
while the installer is running, but stops working after the first reboot.  The
system has an Intel motherboard and works with uhci and usb-uhci drivers.
Adding "alias usb-controller uhci" to /etc/modules.conf fixes the problem.

Comment 6 Bill Nottingham 2003-02-28 00:07:48 UTC
Does this persist with Phoebe?

Comment 7 Bill Nottingham 2003-07-30 23:24:33 UTC
Closed, no response


Note You need to log in before you can comment on or make changes to this bug.