Bug 57893 - RPM manpage out of date: lists illegal build option --test
RPM manpage out of date: lists illegal build option --test
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-30 23:10 EST by tbryan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-01 17:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tbryan 2001-12-30 23:10:42 EST
Description of Problem:
The RPM man page states:
       --test Do not execute any build stages.  Useful for  test-
              ing out spec files.
but RPM does not accept the --test option for build commands, 
such as rpm -ba.


Version-Release number of selected component (if applicable):
$ rpm -q rpm
rpm-4.0.2-8

How Reproducible:
Every time

Steps to Reproduce:
1. unpack any .src.rpm
2. run a command similar to
$ rpm -ba --test egenix-mx-base.spec


Actual Results:
--test: unknown option

Expected Results:
I expected the option to function as described in the man page. :)

Additional Information:
 rpm --help does not list the --test option for rpm build.  The man page 
does.  The command does not accept it.  I'm not sure whether this is a 
bug in RPM (not accepting --test) or a bug in the man page (listing 
--test).  This bug is especially annoying since the versions of the 
_Maximum_RPM_ book currently available online list this option.

The documentation situation for RPM is really deplorable.  As a 
programmer who also groks makefiles and has used Red Hat since 5.2, I was 
surprised how difficult it was to find adequate clear and *current* 
documentation for creating my own RPMs.  It would help if the existing 
documentation didn't lie. ;-)

I also kept step-by-step notes for creating a .spec file.  I'd clean them 
up if you'd like to include them in /usr/share/doc/rpm-4.0.2/, but I'm 
not sure how to submit such documentation.  A separate feature 
enhancement request?
Comment 1 tbryan 2002-01-01 17:57:30 EST
I just upgraded to Red Hat 7.2, and the man page no longer lists --test as a 
build option.  So it appears that the bug is already resolved...unless you 
want more documentation. 


Note You need to log in before you can comment on or make changes to this bug.