Bug 578960 - virtualization guide recommends non-existent package virtio-win
Summary: virtualization guide recommends non-existent package virtio-win
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: virtualization-guide
Version: devel
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Fedora Documentation Project
QA Contact: Nobody's working on this, feel free to take it
URL:
Whiteboard:
: 612537 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-01 21:42 UTC by Eric Blake
Modified: 2015-11-09 03:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-09 03:48:30 UTC


Attachments (Terms of Use)

Description Eric Blake 2010-04-01 21:42:43 UTC
Description of problem:
Section 9.1 mentions the need to download the Windows drivers to take advantage of virtio, and states that the virtio-win package provides those drivers as an iso image.  However, on Fedora 12, 'yum install virtio-win' fails because there is no such package.  I had to do a google search, and eventually found https://sourceforge.net/projects/kvm/files/kvm-driver-disc/ providing the same drivers.


Version-Release number of selected component (if applicable):
Edition 1


How reproducible:
Always (documentation bug).


Steps to Reproduce:
1. try to download virtio-win, using 'yum install virtio-win'
2.
3.
  
Actual results:
There is no virtio-win package in fedora.


Expected results:
The documentation needs updating to describe a working procedure for getting virtio drivers for Windows guests, and/or add a virtio-win package to Fedora that provides the promised files.

Additional info:

Comment 1 Christopher Curran 2010-04-06 01:01:21 UTC
There should be a package for this. It is packaged, I'll find it and update. There is a really significant Virtualization Guide update coming this week, it may take a little longer to get on the site though.

Chris

Comment 3 David Nalley 2010-10-11 13:10:18 UTC
*** Bug 612537 has been marked as a duplicate of this bug. ***

Comment 4 Karsten Wade 2011-12-14 03:47:37 UTC
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!

Comment 5 Steven Moix 2014-07-23 11:34:14 UTC
I'm closing this as it's 3 years old and pretty much worthless at this point ;)

Comment 6 Frediano Ziglio 2015-04-28 13:28:34 UTC
At http://docs.fedoraproject.org/en-US/Fedora/13/html/Virtualization_Guide/chap-Virtualization-KVM_Para_virtualized_Drivers.html there is still same issue, documentation refer to a missing package.

Comment 7 Glen Rundblom 2015-11-09 03:48:30 UTC
Fixed this in the F13 branch docbook source. However the doc is very deprecated and may not show up in the website. This bug and doc is several years old and is probably no longer relevant. However the source has been edited. Closing.

Comment 8 Glen Rundblom 2015-11-09 03:49:56 UTC
Forgot to add, 
to get the virtio drivers:
https://fedoraproject.org/wiki/Windows_Virtio_Drivers


Note You need to log in before you can comment on or make changes to this bug.