Bug 57898 - FTP client or NIC slowness
Summary: FTP client or NIC slowness
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-31 09:10 UTC by Fred New
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 07:57:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred New 2001-12-31 09:10:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461; 
Q312461)

Description of problem:
It takes an extremely long time to download files using the FTP client on 
my RH7.2 machine, even from computers on our LAN.  This is an intermittent 
problem occuring more that 50% of the time.

I didn't have this problem with RH7.1.  This may be related to my NIC, a 
CNet PRO200(B), that should be using the dmfe driver.

For my latest example of this problem, I rebooted to see if I could get 
the problem to go away.  ifconfig currently shows a high number of errors 
on the RX packets line for eth0 (text copied by hand):

Link encap:Ethernet  HWaddr 00:80:AD:76:78:8D
inet addr:x.x.x.103  Bcast:x.x.x.127 Mask:255.255.255.224
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:3563 errors:2980 dropped:0 overruns:0 frame:0
TX packets:1673 errors:3 dropped:0 overruns:0 carrier:3
collisions:0 txqueuelen:100
RX bytes:2555692 (2.4 Mb)  TX bytes:135371 (132.1 Kb)
Interrupt:9 Base address:0xe800


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.  ftp wolf (Solaris 2.6)
2.  bi
3.  mget file*
4.  wait several minutes
5.  respond "y" to mget prompt
6.  Go to alternate character-mode console and watch download progress.  
Wait several minutes before file starts downloading.
7.  etc.

	

Expected Results:  I don't usually experience long wait times in steps 4 
and 6 above.

Additional info:

My NIC is talking to a 3Com SuperStack II Switch 3900-36 (rev CA).  I 
don't suspect this has anything to do with the problem since the NIC 
worked as expected under RH7.1.

By the way, my RH7.1 system had all of the latest patches, including 
kernel upgrades, before I started using RH7.2 about a month ago.  (And I 
had a minor problem with RH7.1 when the dmfe driver was missing from one 
of the kernel upgrades.)  I formatted my /, /usr, /var file systems when I 
installed RH7.2, but I kept the data on the /home file system.

Comment 1 Michael K. Johnson 2002-01-04 17:17:08 UTC
What kernel version are you using now, and what was the last working
kernel version you had with 7.1?

Comment 2 Fred New 2002-01-07 07:57:06 UTC
My apologies.  I remembered after I submitted this report that I had also 
changed the computer, but kept the same NIC.  And thanks to your question about 
the kernel, I would tend to believe that my problem is hardware related.  The 
old 7.1 kernel was 2.4.9-12 (i586) and for 7.2 it is 2.4.9-13 (i686).  (The old 
computer had a 120 MHz Pentium and the new one has a 233 MHz Pentium II.)  I 
have also compiled the 2.4.16 kernel and it is giving me the same poor results.

Please close this report.  If I can, I'll experiment with other computers and 
versions 7.1 and 7.2.  If I find a real problem, I'll report back.


Note You need to log in before you can comment on or make changes to this bug.