Bug 57902 - Xvfb (X virtual frame Buffer) produces error message indefinitely upon startup
Xvfb (X virtual frame Buffer) produces error message indefinitely upon startup
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-31 15:10 EST by Gilbert Sebenste
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 09:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gilbert Sebenste 2001-12-31 15:10:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Win98; U)

Description of problem:
When I use rc.local or hand-start Xvfb, such as using the command: /usr/X11R6/bin/Xvfb :1 -screen 0 1280x1024x16 &
I get the following error message that pops up on the command line or opening screen once every 2 seconds or so:
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
My machine has crashed fairly frequently since I put 7.2 on several weeks ago. Since I stopped Xvfb, it hasn't crashed...so far, anyway. I 
am 
using a dual Pentium 2 450 MHZ machine from SWTechnologies. This error message occurs whenever you start Xvfb: by using rc.local, 
going into /etc/rc.d/init.d and typing ./xvfb start, or the command above. Also...I have this same problem on a single processor P2, and a 
friend of mine who also has the same Redhat Version (7.2) at Iowa State reports the same thing. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type: /etc/rc.d/init.d/xvfb start, or see above.
2.
3.
	

Actual Results:  I got the error message described above.

Expected Results:  No errors should have occurred.

Additional info:

That's it!
Comment 1 Gilbert Sebenste 2001-12-31 15:16:47 EST
Also...an unrelated thing (maybe)? Xvfb windows fail under high load, magically disappearing. Making graphics for a web site, I  need this capability. 
Under heavy load, Xvfb "windows" crash/disappear in less than 8 hours. -Gilbert Sebenste
Comment 2 Mike A. Harris 2002-01-24 22:17:40 EST
The message isn't an error, it is a warning.  Your configuration
is including a font path, which does not actually contain any fonts.

Remove the errant font paths from your xfs and/or X server
configuration, and restart, and the warnings should go away.

Note You need to log in before you can comment on or make changes to this bug.