Bug 57905 - Ide-scsi with two cdroms on one bus cause kernel oops
Ide-scsi with two cdroms on one bus cause kernel oops
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-31 15:51 EST by Joe Krahn
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-31 15:51:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Krahn 2001-12-31 15:51:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78C-MyBrowser [en] (X11; U; Linux 2.4.9-13-jk1 i686)

Description of problem:
I have two cdroms on one bus, originally both mounted
through ide-scsi. Putting a load on both disks at the same
time (with rsync) gave an oops with the message "Aiee, killing interrupt
handler". According to EIP/System.map, its crashing
in ide_build_sglist. (I believe I need a serial connection to get the full
oops message here, or copy by hand which I didn't do)

It crashes reliably, but not immediately.
Mounting one drive ide-cd and one ide-scsi still crashes.
Appears to work OK to load one cdrom via ide-scsi and leave
the other cdrom unused (or it at least greatly reduces
the odds of crashing.)
Mounting both with ide-cd works OK, but is not very nice
if you want be able to use cdrecord on one of them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount two cdrom's on one IDE bus,
2. On both drives, run something like: "rsync -avc /mnt/cdrom remote:/xxx"
or probably any command to put a heavy read load on the drives
3.
	

Actual Results:  Kernel Oops in ide_build_sglist

Expected Results:  Not crashing...

Additional info:

I am using the standard 2.4.9-13 i686 kernel.
System is a Dell Dimension 8200 with pentium 4 2.0 GHz processor.
(Maybe it's doing something too fast?)
IDE controller is an intel 82801BA.

Maybe there's some ide parameters one can use at boot time,
but this would probabyl be more of a work-around than a fix.

I can some more debugging if you give me a hint.
Comment 1 Joe Krahn 2002-05-14 15:40:53 EDT
Seems to be OK on newer kernels. Since nobody else has
reported this problem, I'll mark it as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.