Bug 57906 - Bad: System crashes with gdth raid controller
Summary: Bad: System crashes with gdth raid controller
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-31 22:00 UTC by J.M.Roth
Modified: 2007-04-18 16:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-06-08 00:03:41 UTC


Attachments (Terms of Use)

Description J.M.Roth 2001-12-31 22:00:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I don't have much details. I installed a new server. I upgraded to 2.4.9-
13enterprise kernel using up2date. After a day it first hung. Even the 
switchbox it was connected to sort of "hung" it that server was selected. 
Today, same thing. Ping is still working although. Gonna take a look 
tomorrow. Dual PIII system with gdth raid controller. 1 GB RAM. Very 
annoying.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn it on
2. Way a day or two
3. Push the reset button
	

Additional info:

Comment 1 J.M.Roth 2002-01-01 00:32:12 UTC
It sounds odd and it may be a coincidence but I was connected via SSH with the 
F-Secure Windows SSH Client. My laptop unexpectedly went into hibernation while 
the connection etc. was still up. I immediately rebooted and then I couldn't 
reach the server anymore. I can ping it but nothing else.

Comment 2 J.M.Roth 2002-01-01 00:43:17 UTC
Need more info? Take a look at RHN profile cents.iip.lu
Sorry, but I'm anxious about getting this fixed!!
Happy new year BTW

Comment 3 Arjan van de Ven 2002-01-01 09:11:22 UTC
Can you try adding "mem=800M" on the kernel commandline (in /boot/grub/grub.conf
on the vmlinuz line, if you use grub)

Comment 4 Arjan van de Ven 2002-01-01 15:53:08 UTC
Also, it might be interesting to try the kernel at
http://people.redhat.com/arjanv/testkernels
which has a few bugs fixed; one could be hit on your machine....

Comment 5 J.M.Roth 2002-01-01 16:10:07 UTC
Thanks, I have more information.
The console was still there. One could enter the username but not anymore the 
password.
All the consoles were full of this errors:
ext3-fs error
device 08:03 not ready
I/O error: dev 08:03 sector 0


Comment 6 J.M.Roth 2002-01-01 17:08:33 UTC
I found something that might be related
http://groups.google.com/groups?
q=kernel+gdth++bug+2.4&hl=en&scoring=d&rnum=1&selm=linux.smp.OE26fLJGWSa1aNEVJpj
0000805b%40hotmail.com
I can't *try* much since this is a production system.
Is the gdth driver up to date? The latest version is 2.03 which is revision 1.57

Comment 7 J.M.Roth 2002-01-02 10:20:38 UTC
I'm afraid to say the new test kernel didn't help.
I have no debugging info either. The screen was black when it crashed 30 mins
ago. I think I'm gonna try the normal (not SMP) kernel now.

Comment 8 J.M.Roth 2002-01-02 13:42:05 UTC
I downgraded to kernel-2.4.9-13.i586.rpm.
With append "mem=800M". For now its stable.
Note that 2.4.9-17enterprise also crashed.
I'll keep you advised.


Comment 9 J.M.Roth 2002-01-19 16:50:50 UTC
The standard i586 kernel is still running fine...

Comment 10 J.M.Roth 2002-02-15 00:40:18 UTC
2.4.9-21 (NOT SMP) without 800M setting also running fine
must be SMP related (didn't try the new SMP one though)

Comment 11 J.M.Roth 2002-03-19 19:38:51 UTC
Seems to be OK using 2.4.9-31smp


Note You need to log in before you can comment on or make changes to this bug.