Bug 579061 - Review Request: perl-Version-Requirements - Set of version requirements for a CPAN dist
Summary: Review Request: perl-Version-Requirements - Set of version requirements for a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL: http://search.cpan.org/dist/Version-R...
Whiteboard:
Depends On:
Blocks: 579327
TreeView+ depends on / blocked
 
Reported: 2010-04-02 12:21 UTC by Iain Arnell
Modified: 2010-04-20 13:18 UTC (History)
2 users (show)

Fixed In Version: perl-Version-Requirements-0.100660-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-20 13:18:35 UTC
cweyl: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Iain Arnell 2010-04-02 12:21:09 UTC
Spec URL: http://fedorapeople.org/~iarnell/review/perl-Version-Requirements.spec
SRPM URL: http://fedorapeople.org/~iarnell/review/perl-Version-Requirements-0.100660-1.fc14.src.rpm

Description:
A Version::Requirements object models a set of version constraints like
those specified in the META.yml or META.json files in CPAN distributions.
It can be built up by adding more and more constraints, and it will reduce
them to the simplest representation.

Koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2091052

*rt-0.10_01

Comment 1 Chris Weyl 2010-04-02 15:45:06 UTC
Looks good!

koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=2091052

Spec looks sane, clean and consistent; license is correct (GPL+ or Artistic);
make test passes cleanly.

Source tarballs match upstream (sha1sum):
ca793cb37406d65e5f9e888674e0a943b4915c44 Version-Requirements-0.100660.tar.gz
ca793cb37406d65e5f9e888674e0a943b4915c44 Version-Requirements-0.100660.tar.gz.srpm

Final provides / requires are sane:

0 packages and 1 specfiles checked; 0 errors, 0 warnings.
=====> perl-Version-Requirements-0.100660-1.fc14.noarch.rpm <=====
====> rpmlint
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
====> provides for perl-Version-Requirements-0.100660-1.fc14.noarch.rpm
perl(Version::Requirements) = 0.100660
perl-Version-Requirements = 0.100660-1.fc14
====> requires for perl-Version-Requirements-0.100660-1.fc14.noarch.rpm
perl(Carp)  
perl(:MODULE_COMPAT_5.10.1)  
perl(Scalar::Util)  
perl(strict)  
perl(version) >= 0.77
perl(warnings)  

=====> perl-Version-Requirements-0.100660-1.fc14.src.rpm <=====
====> rpmlint
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
====> provides for perl-Version-Requirements-0.100660-1.fc14.src.rpm
====> requires for perl-Version-Requirements-0.100660-1.fc14.src.rpm
perl(ExtUtils::MakeMaker)  
perl(Pod::Coverage::TrustPod)  
perl(Test::More) >= 0.88
perl(Test::Pod)  
perl(Test::Pod::Coverage)  
perl(version) >= 0.77

APPROVED

Comment 2 Iain Arnell 2010-04-02 16:21:14 UTC
New Package CVS Request
=======================
Package Name: perl-Version-Requirements
Short Description: Set of version requirements for a CPAN dist
Owners: iarnell
Branches: F-11 F-12 F-13
InitialCC: perl-sig

Comment 3 Kevin Fenzi 2010-04-03 17:44:06 UTC
CVS done (by process-cvs-requests.py).

Comment 4 Fedora Update System 2010-04-04 07:08:22 UTC
perl-Version-Requirements-0.100660-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/perl-Version-Requirements-0.100660-1.fc13

Comment 5 Fedora Update System 2010-04-06 19:54:38 UTC
perl-Version-Requirements-0.100660-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Version-Requirements'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/perl-Version-Requirements-0.100660-1.fc13

Comment 6 Fedora Update System 2010-04-20 13:18:30 UTC
perl-Version-Requirements-0.100660-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.