This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 579106 - no option to enter custom partition layout in text mode installer
no option to enter custom partition layout in text mode installer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 12:59 EDT by Bingo
Modified: 2010-04-02 14:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-02 14:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bingo 2010-04-02 12:59:28 EDT
Description of problem:
Installing Fedora 13, Alpha from DVD. X could not be started during installation so installing in text mode. When coming to partition selection, there is no option to create a custom partition layout. Only options are:
1. Use entire disk
2. Use free space
3. Overwrite other linux installations

Choosing any of them results in ext4 partition created, with LVM.

No option to create different /home, /tmp etc. partitions. No option to choose filesystems other than ext4. No option to vary the size of swap. It is a regression from Fedora 12.

Version-Release number of selected component (if applicable):
Text mode Installation software of Fedora Alpha 13, 64 bit

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 13 Alpha, 64 bit, in text mode from DVD.
2. No option to create custom disk layout.
3.
  
Actual results:
No option to create custom disk layout.

Expected results:
Option to be provided to create custom disk layout.

Additional info:
Comment 1 Rahul Sundaram 2010-04-02 13:45:16 EDT
Text mode from Fedora 11 release onwards is a very minimal installation. 

http://docs.fedoraproject.org/release-notes/f11/en-US/sect-Release_Notes-Installation_Notes.html

So that part is not a bug.   Unless you have low end hardware,  the installer should be able to detect the hardware and start the graphical installer.    If you do have low end harware,  vnc installation might be preferable to you.  

Can you provide the system specifications?  Especially the RAM and graphics hardware details.  Thanks
Comment 2 Bingo 2010-04-02 14:27:30 EDT
Hardware: VirtualBox.

Thanks for the update. I am disappointed by feature-drain from text-mode installation. Was hoping to try out btrfs.

I was trying out Fedora 13 in a virtual machine. Seems like VirtualBox has problems(http://www.virtualbox.org/ticket/6370)  with new version of Xorg, so not surprising that X did not run.
Comment 3 Rahul Sundaram 2010-04-02 14:51:25 EDT
Yeah.  Perhaps you can try another virtualization solution like KVM with virt-manager.   I am closing this bug report because the minimal text mode installation is intentionally that way.   Thanks for your feedback.

Note You need to log in before you can comment on or make changes to this bug.