Bug 579123 - Fedora 12 GUI crashes consistently after a variable, but small number of mouse driven operations.
Summary: Fedora 12 GUI crashes consistently after a variable, but small number of mous...
Keywords:
Status: CLOSED DUPLICATE of bug 571525
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-02 18:36 UTC by David J Weiner
Modified: 2018-04-11 18:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 14:02:19 UTC


Attachments (Terms of Use)
Xorg.0.log file after crash, before reboot. (11.55 KB, text/plain)
2010-04-02 18:41 UTC, David J Weiner
no flags Details
Log file after GUI crash, before reboot (11.55 KB, text/plain)
2010-05-21 15:47 UTC, David J Weiner
no flags Details

Description David J Weiner 2010-04-02 18:36:14 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Computer use:
The computer in question is mainly a backup server and is managed mostly remotely using SSH. Anything done using SSH works fine, as do all operations done locally using terminal.
Problem description:
After what seems like a variable, but low number of manipulations (1-10) using the mouse, the screen goes blank and my session is closed. The problem seems associated with a window-create call and can be just a cursor hover, say over the F (lower left). After the session crash, I can SSH into the box from another Fedora machine and do whatever I like, but locally the mouse and keyboard seem unresponsive. After an occurance the X11 process is gone from the list of processes (top).

Reproducible: Always

Steps to Reproduce:
1.login to a GUI session
2.open and close several windows. For example try to use Dolphin to "drill" down to a file.
3.
Actual Results:  
Eventually the screen goes blank, the keyboard and mouse are unresponsive. I am no longer logged on as determined by SSH from another Fedora box.

Expected Results:  
Successful use of a file.

General:
FC12 was installed onto a clean disk. 
Updated weekly, and continues to be so. 
Using KDE, but also has Gnome installed. 
At first this problem occured only rarely (2-3 times/week) with light local GUI use. Beginning about 5 or 6 updates ago, the problem has grown worse. At present it's only a matter of time before it occurs- within 10 minutes of logon to a fresh boot.

Diagnostic information:
The ABRT system does not catch this problem.
I have looked at the X11 logs and found the attached log after the occurance of the problem, but before any reboot or any other manipulation other than a cp. Note the last entries.
No other logs make any reference to the problem.
The problem occurs with both KDE and Gnome and after a reinstall of all of the X11 files and the Intel driver using yum.
I have tried using the last two kernel versions with no change.
I have tried "nomodeset" as a kernel parameter with no change in behavior.

Machine description:
Gateway series 310 machine
Integrated video using a 82845GV graphics and memory controller, described as "Intel Extreme Graphics controller".
2 Gigs of memory matched from Gateway's list of acceptable memory.
Celeron processor at 2.6 GHz.
2 500 Gig Western digital drives.
Running FC12 up to date.

Comment 1 David J Weiner 2010-04-02 18:41:31 UTC
Created attachment 404225 [details]
Xorg.0.log file after crash, before reboot.

Although I'm sure that I don't know about all log files, this is the only one that seems to have any entries concerning the crash.

Comment 2 David J Weiner 2010-05-21 15:44:31 UTC
After each update (usually on Fri) that has anything to do with the  kernel or X, I test for the bug. After the past two updates, I have noted a difference in behavior which may or may not be important. It's hard to tell because of the somewhat irregular nature of the crashes. After the update on April 23, for the first time, the GUI crashed immediately after logon, just as the welcome music began. After the last update on May 15, it crashed upon reboot as the logon screen was displayed. I don't know if this is any diagnostic help, or if it's really different.

Comment 3 David J Weiner 2010-05-21 15:47:02 UTC
Created attachment 415718 [details]
Log file after GUI crash, before reboot

Comment 4 Matěj Cepl 2010-05-24 14:02:19 UTC

*** This bug has been marked as a duplicate of bug 571525 ***


Note You need to log in before you can comment on or make changes to this bug.