Bug 579124 - Proper icon resolution instead of scaling for Transmission
Summary: Proper icon resolution instead of scaling for Transmission
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: transmission
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-02 18:36 UTC by Misha Shnurapet
Modified: 2010-05-22 01:47 UTC (History)
5 users (show)

Fixed In Version: transmission-1.93-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-22 01:46:08 UTC


Attachments (Terms of Use)
An icon of unfit resolution being used in the system notification area (7.07 KB, image/png)
2010-04-02 18:36 UTC, Misha Shnurapet
no flags Details

Description Misha Shnurapet 2010-04-02 18:36:21 UTC
Created attachment 404224 [details]
An icon of unfit resolution being used in the system notification area

An icon of wrong resolution is used as the tray icon for Transmission. The attached screenshot shews the difference and the correct icon.

Steps to reproduce:
1. Run Transmission;
2. Go to Preferences;
3. Turn the tray icon on.

This icon is always used, even after re-logging in.

Comment 1 Ankur Sinha (FranciscoD) 2010-04-04 06:22:52 UTC
(In reply to comment #0)
> Created an attachment (id=404224) [details]
> An icon of unfit resolution being used in the system notification area
> 
> An icon of wrong resolution is used as the tray icon for Transmission. The
> attached screenshot shews the difference and the correct icon.
> 
> Steps to reproduce:
> 1. Run Transmission;
> 2. Go to Preferences;
> 3. Turn the tray icon on.
> 
> This icon is always used, even after re-logging in.    

hey,

I'm sorry I fail to see the difference here :$

Can you please give a better description of the difference in icons? They screenshot shows nothing. 

regards,
Ankur

Comment 2 Martin Sourada 2010-04-04 11:33:36 UTC
Well, it might be a insignificant difference for an untrained healthy eye, but the icon on the bottom is optimised for the resolution it is displayed at, while the top one is just scaled down version of probably SVG optimised for 48x48. The bottom icons has visible outlines and isn't blurry anywhere (as opposed to the top one). This helps especially visually impaired people.

Comment 3 Misha Shnurapet 2010-04-04 11:40:18 UTC
Thank you, Martin.

Comment 4 Ankur Sinha (FranciscoD) 2010-04-05 11:57:37 UTC
(In reply to comment #2)
> Well, it might be a insignificant difference for an untrained healthy eye, but
> the icon on the bottom is optimised for the resolution it is displayed at,
> while the top one is just scaled down version of probably SVG optimised for
> 48x48. The bottom icons has visible outlines and isn't blurry anywhere (as
> opposed to the top one). This helps especially visually impaired people.    

hey,

Thank you for the clarification. We're looking into it.

regards,
Ankur

Comment 5 Fedora Update System 2010-05-02 22:24:11 UTC
transmission-1.93-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/transmission-1.93-1.fc13

Comment 6 Fedora Update System 2010-05-02 22:40:54 UTC
transmission-1.93-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/transmission-1.93-1.fc12

Comment 7 Charles Kerr 2010-05-02 23:32:55 UTC
I think this is fixed in 1.93.  This seems to be the same as upstream http://trac.transmissionbt.com/ticket/3179

Comment 8 Fedora Update System 2010-05-04 06:02:27 UTC
transmission-1.93-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update transmission'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/transmission-1.93-1.fc12

Comment 9 Fedora Update System 2010-05-04 06:24:43 UTC
transmission-1.93-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update transmission'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/transmission-1.93-1.fc13

Comment 10 Fedora Update System 2010-05-22 01:45:54 UTC
transmission-1.93-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-05-22 01:47:02 UTC
transmission-1.93-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.