Bug 579131 - [abrt] crash in psi-0.14-1.fc13: Process /usr/bin/psi was killed by signal 6 (SIGABRT)
[abrt] crash in psi-0.14-1.fc13: Process /usr/bin/psi was killed by signal 6 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: psi (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
abrt_hash:74dc57bf9497498d322da8ed82c...
:
: 579673 (view as bug list)
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2010-04-02 15:12 EDT by Raphael Groner
Modified: 2010-04-20 09:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: psi-0.14-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-20 09:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.83 KB, text/plain)
2010-04-02 15:12 EDT, Raphael Groner
no flags Details
Disable Qt debugging macros (265 bytes, patch)
2010-04-04 09:31 EDT, Sergey Fionov
no flags Details | Diff

  None (edit)
Description Raphael Groner 2010-04-02 15:12:44 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: psi
comment: psi crashes
component: psi
executable: /usr/bin/psi
kernel: 2.6.33.1-19.fc13.x86_64
package: psi-0.14-1.fc13
rating: 4
reason: Process /usr/bin/psi was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. install psi-icons
2. start psi
3. select in menu options/appearance/icons
Comment 1 Raphael Groner 2010-04-02 15:12:47 EDT
Created attachment 404228 [details]
File: backtrace
Comment 2 Raphael Groner 2010-04-03 13:23:56 EDT
It seems to be related to a failing assert statement. 

Please rebuild the package without debug support at all.
Comment 3 Sergey Fionov 2010-04-03 13:34:56 EDT
Seems that there are wrong configure options.

"--debug --no-separate-debug-info" flags disable QT_NO_DEBUG macro, that makes
Q_ASSERTs fatal. It is incorrect behaviour for package that is not to be used
to develop Psi. When Qt debug is not enabled, all asserts are ignored.

I think that "release" version should be built, with debug compiler flags
enabled for debuginfo packages (and qt debug flags disabled).
Comment 4 Raphael Groner 2010-04-03 15:03:49 EDT
Workaround:
Remove those three files from /usr/share/psi/iconsets:
  emoticons/gadu_gadu.jisp, roster/kitty.jisp and roster/dudes32.jisp
Comment 5 Sergey Fionov 2010-04-04 09:31:05 EDT
Created attachment 404397 [details]
Disable Qt debugging macros

The proposed patch adds QT_NO_DEBUG define to disable Qt debugging macros. Due to "debug" config option debuginfo will not be lost.

With this patch Psi doesn't abort on incorrect iconsets as in "release" build.
Comment 6 Fedora Update System 2010-04-05 01:42:14 EDT
psi-0.14-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/psi-0.14-2.fc13
Comment 7 Raphael Groner 2010-04-05 10:41:23 EDT
(In reply to comment #6)
> psi-0.14-2.fc13 has been submitted as an update for Fedora 13.
> http://admin.fedoraproject.org/updates/psi-0.14-2.fc13    

Bugfix confirmed. Above described behaviour (crash) does not occur any more.
Thanks for the quick patch!
Comment 8 Sven Lankes 2010-04-06 04:45:43 EDT
*** Bug 579673 has been marked as a duplicate of this bug. ***
Comment 9 David Kovalsky 2010-04-06 05:06:48 EDT
Is there going to be an F12 update too? My F12 bug 579673 has been closed as a duplicate of this one.
Comment 10 Fedora Update System 2010-04-06 15:56:47 EDT
psi-0.14-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update psi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/psi-0.14-2.fc13
Comment 11 Sven Lankes 2010-04-06 16:14:14 EDT
(In reply to comment #9)

> Is there going to be an F12 update too? My F12 bug 579673 has been closed as a
> duplicate of this one.    

Sorry. I should have added a note when closing your bug. An update is also available for F12: https://admin.fedoraproject.org/updates/psi-0.14-2.fc12
Comment 12 David Kovalsky 2010-04-07 04:19:57 EDT
Thanks Sven! :)
Comment 13 Raphael Groner 2010-04-07 15:39:38 EDT
Who is responsible for closing this bug? 

Can I (as the reporter) close it?
I have verified the patched package is now available in repository.
Comment 14 Aurelien Bompard 2010-04-07 15:47:11 EDT
The bug will be closed when the package is moved to the stable repo. No need to do it yourself, but thanks anyway :)
Comment 15 Ville Skyttä 2010-04-07 15:50:52 EDT
This change has made -debuginfo probably useless, I suppose (based on quick
look at the build log and -debuginfo no longer having sources) because the
build now strips objects before rpmbuild has had a chance to do it.  See
blocker bug for more info.
Comment 16 Raphael Groner 2010-04-07 15:55:48 EDT
(In reply to comment #13)

I am able to test only with rawhide. Therefore and due to the duplication of bug (comments #8 to #11), I am not sure about Version and Platform. Bug seems to exist since F11. And besides x86_64 also for i686?
Comment 17 Aurelien Bompard 2010-04-07 15:58:03 EDT
> This change has made -debuginfo probably useless

OK, any way to keep the objects unstripped and not crash on failed assertions ?
Comment 18 Sergey Fionov 2010-04-07 16:14:54 EDT
I suggest to add QT_NO_DEBUG define which disables qt debugging macros, instead of switching off debug. See my comment #5 and patch.
Comment 19 Ville Skyttä 2010-04-07 16:17:23 EDT
Based on comments 3, 4, and 18 I gather stripping is not the issue (that would be
very rare), it's the other things that the --debug and --no-separate-debug-info
do.  No matter whether those are left in or out, it should be ensured that the upstream build respects $RPM_OPT_FLAGS and does not attempt any stripping itself, by patching if necessary.
Comment 20 Raphael Groner 2010-04-07 18:04:23 EDT
Updated package from repository is okay for me.

Name       : psi
Architektur : x86_64
Version    : 0.14
Ausgabe    : 2.fc13
Grösse     : 6.5 M
Repo       : installed
Aus repo    : updates-testing
Comment 21 Fedora Update System 2010-04-08 01:42:24 EDT
psi-0.14-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/psi-0.14-3.fc13
Comment 22 Fedora Update System 2010-04-09 00:15:12 EDT
psi-0.14-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update psi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/psi-0.14-3.fc13
Comment 23 Fedora Update System 2010-04-20 09:14:17 EDT
psi-0.14-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.