Bug 57919 - Lynx guesses protocol wrong
Lynx guesses protocol wrong
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lynx (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
fingerhosting.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-01 14:00 EST by Rick van Rein
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 09:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick van Rein 2002-01-01 14:00:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The command "lynx fingerhosting.com" assumes wrongly that it should
use the finger protocol, based on the initial portion of the URL.
Since the beginning is "finger" not "finger:" (mark the colon), this
is a bit over-enthousiastic guesswork.

Version-Release number of selected component (if applicable):
Lynx Version 2.8.4rel.1 (17 Jul 2001)
libwww-FM 2.14, SSL-MM 1.4.1, OpenSSL 0.9.6b
Built on linux-gnu Jul 31 2001 09:03:10



How reproducible:
Always

Steps to Reproduce:
Any of these will do:
1.lynx fingerhosting.com
2.lynx fingerprint.org
3.(etc)
	

Actual Results:
1. it displays the "finger" protocol results which are available here
2. no finger daemon, so lynx goes through these phases:
Looking up fingerprint.org first
Looking up fingerprint.org
Making finger connection to fingerprint.org
Alert!: Could not access finger host.

lynx: Can't access startfile finger://fingerprint.org/


Expected Results:  Display of the "http" protocol results, aka the web
page, for the named domains. Lynx is by default a web browser, after all,
and the name of the domain is undesirable to influence the protocol choice!

Additional info:

I am working on a modernised version of finger, namely one that is
based on domains instead of hosts. So that we may finger an email
address again, to find PGP info and visitor's cards. Would it be a
good idea to submit it to RedHat, and if so, how would that work?
The improvement enables virtual hosting including redundancy. Overdone
for finger, but it definately demonstrates what redundancy can do, and
HOW to do it. More info on fingerhosting.com if you're interested.
Comment 1 Bernhard Rosenkraenzer 2002-01-08 09:59:03 EST
That's a matter of taste...
Someone trying something along the lines of

lynx fingerserver02.internal

will expect a different behavior...
I'm not sure which is preferrable.
Comment 2 Bernhard Rosenkraenzer 2002-01-10 12:47:07 EST
Talked with one of the maintainers; they think the current behavior is intended (basically for the example I mentioned earlier).

Note You need to log in before you can comment on or make changes to this bug.