Bug 579214 - Error when checking out python-fedora anonymously
Summary: Error when checking out python-fedora anonymously
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bzr
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-03 11:20 UTC by Ville Skyttä
Modified: 2010-05-19 02:37 UTC (History)
4 users (show)

Fixed In Version: loggerhead-1.17-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-13 16:55:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 528041 None None None Never

Description Ville Skyttä 2010-04-03 11:20:46 UTC
Following the instructions at https://fedorahosted.org/python-fedora/wiki/Downloads I tried to check out python-fedora anonymously, but got this with bzr-2.1.1-1.fc13.x86_64:


$ bzr branch bzr://bzr.fedorahosted.org/bzr/python-fedora/python-fedora-devel
Server does not understand Bazaar network protocol 3, reconnecting.  (Upgrade the server to avoid this.)
bzr: ERROR: exceptions.AssertionError: _remember_remote_is_before((2, 1)) called, but _remember_remote_is_before((1, 6)) was called previously.

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/bzrlib/commands.py", line 853, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/bzrlib/commands.py", line 1055, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib64/python2.6/site-packages/bzrlib/commands.py", line 661, in run_argv_aliases
    return self.run_direct(**all_cmd_args)
  File "/usr/lib64/python2.6/site-packages/bzrlib/commands.py", line 665, in run_direct
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/bzrlib/builtins.py", line 1194, in run
    from_location)
  File "/usr/lib64/python2.6/site-packages/bzrlib/bzrdir.py", line 958, in open_tree_or_branch
    bzrdir = klass.open(location)
  File "/usr/lib64/python2.6/site-packages/bzrlib/bzrdir.py", line 843, in open
    return BzrDir.open_from_transport(t, _unsupported=_unsupported)
  File "/usr/lib64/python2.6/site-packages/bzrlib/bzrdir.py", line 878, in open_from_transport
    return format.open(transport, _found=True)
  File "/usr/lib64/python2.6/site-packages/bzrlib/bzrdir.py", line 2088, in open
    return self._open(transport)
  File "/usr/lib64/python2.6/site-packages/bzrlib/bzrdir.py", line 3327, in _open
    return remote.RemoteBzrDir(transport, self)
  File "/usr/lib64/python2.6/site-packages/bzrlib/remote.py", line 115, in __init__
    self._probe_bzrdir()
  File "/usr/lib64/python2.6/site-packages/bzrlib/remote.py", line 130, in _probe_bzrdir
    medium._remember_remote_is_before((2, 1))
  File "/usr/lib64/python2.6/site-packages/bzrlib/smart/medium.py", line 615, in _remember_remote_is_before
    % (version_tuple, self._remote_version_is_before))
AssertionError: _remember_remote_is_before((2, 1)) called, but _remember_remote_is_before((1, 6)) was called previously.

bzr 2.1.1 on python 2.6.4 (Linux-2.6.32.10-92.fc12.x86_64-x86_64-with-fedora-13-Goddard)
arguments: ['/usr/bin/bzr', 'branch', 'bzr://bzr.fedorahosted.org/bzr/python-fedora/python-fedora-devel']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_US.UTF-8'
plugins:
  launchpad            /usr/lib64/python2.6/site-packages/bzrlib/plugins/launchpad [2.1.1]
  netrc_credential_store /usr/lib64/python2.6/site-packages/bzrlib/plugins/netrc_credential_store [2.1.1]
  news_merge           /usr/lib64/python2.6/site-packages/bzrlib/plugins/news_merge [2.1.1]

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

Comment 1 Toshio Ernie Kuratomi 2010-04-06 16:48:36 UTC
Found an upstream report.  It's a bug in the smart server code: https://bugs.launchpad.net/bzr/+bug/528041

One workaround would be to get bzr updated in Fedora Infrastructure (and maybe EPEL... it's API is incompatible which is why we haven't updated but incompatibility of the server with current clients is also a problem).  For Infrastructure we'd need to get loggerhead packaged and running under mod_wsgi in order to upgrade bzr (as the current bazaar-webserve code won't work with the new API and is pretty dead upstream).

Comment 2 Fedora Update System 2010-04-13 12:46:19 UTC
qbzr-0.19-0.1.b1.el5,loggerhead-1.17-4.el5,trac-bazaar-plugin-0.3.3-1.el5,bzr-gtk-0.98.0-2.el5,bzrtools-2.1.0-3.el5,bzr-2.1.1-3.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/qbzr-0.19-0.1.b1.el5,loggerhead-1.17-4.el5,trac-bazaar-plugin-0.3.3-1.el5,bzr-gtk-0.98.0-2.el5,bzrtools-2.1.0-3.el5,bzr-2.1.1-3.el5

Comment 3 Toshio Ernie Kuratomi 2010-04-13 13:09:55 UTC
I've already upgraded the fedorahosted servers with the new bzr packages.  Can you verify that Fedora 13 can now pull from fedorahosted?

Comment 4 Ville Skyttä 2010-04-13 15:27:22 UTC
Yes, works now (still with bzr-2.1.1-1.fc13.x86_64).  Thanks.

Comment 5 Toshio Ernie Kuratomi 2010-04-13 16:55:32 UTC
Excellent.

Comment 6 Fedora Update System 2010-05-19 02:37:25 UTC
loggerhead-1.17-6.el5, qbzr-0.19-0.1.b1.el5, trac-bazaar-plugin-0.3.3-1.el5, bzr-gtk-0.98.0-2.el5, bzrtools-2.1.0-3.el5, bzr-2.1.1-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.