Bug 57924 - ifup support for PPPoE broken
ifup support for PPPoE broken
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-01-01 20:54 EST by Craig Lawson
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-02-06 22:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Craig Lawson 2002-01-01 20:54:22 EST
Description of Problem:
  Unable to start eth0 automatically at boot for use with PPPoE

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. Configure /etc/sysconfig/network-scripts/ifcfg-eth0 with:
2. Restart the network: /etc/init.d/network restart

Actual Results:
The network script claims to have successfully brought up eth0, but
ifconfig shows that eth0 is down.

Expected Results:
I expected eth0 to be up.

Additional Information:
  A work-around is to manually run "ifconfig eth0 up". Works fine. I can
successfully start PPPoE after that.

  This all worked fine before I updated my system with up2date. I tracked
down the trouble to the "ifup". A previous version this script (sorry, I
don't know the package version, but it's probably the one on the RH 7.1 CD)

    if [ -z "${IPADDR}" ]; then
         # enable device without IP, useful for e.g. PPPoE
-        ifconfig ${DEVICE} up ${MTU:+mtu $MTU}
	 exec /etc/sysconfig/network-scripts/ifup-post ${CONFIG} ${2}

where the line preceeded with "-" is missing in initscripts-5.84.1-1.

  As a side note, I tried to use ifenslave to fix this. It didn't work with
 ppp0, otherwise I would use the MASTER=ppp0 and SLAVE=yes values in
ifcfg-eth0. "ifenslave ppp0 eth0" gives the following error message:

  The specified master interface 'ppp0' is not ethernet-like.
    This program is designed to work with ethernet-like network interfaces.
   Use the '-f' option to force the operation.

and "ifenslave -f ppp0 eth0" gives:

  master has no hw address assigned; getting one from slave!
  BOND_SETHWADDR on eth0 failed: Bad address

/sbin/ifenslave is from iputils-20001110-1. There does not seem to be a
dependency between the initscripts and iputils packages.
Comment 1 Bill Nottingham 2002-02-06 22:40:46 EST
Whoops, you're right. This was broken there, and fixed in 7.2. I'll fix this on
the 7.1 branch, but it probably won't go out unless we need to do a 7.1 errata.

Note You need to log in before you can comment on or make changes to this bug.