Bug 57936 - Root's xterm colors unusable
Summary: Root's xterm colors unusable
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-02 18:05 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 00:52:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-01-02 18:05:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Running X as root, running xterm, background and some text colors are the
same, which makes for instance man pages and 'top' useless.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login as root and go into X
2.run xterm or nxterm
3.run e.g. 'top' or 'man xterm'

Actual Results:  Bold characters are white, as is background.  This makes
them invisible

Expected Results:  All text should be a different color from the background.

Additional info:

This is not the case for a regular user login,
Nor does this bite you  if you run X as a regular user then 'su -'.

Comment 1 Mike A. Harris 2002-01-24 20:34:17 UTC
So far, I have been unable to reproduce this problem. It is possible
if there is a bug, that it is due to some differing configurations
between your setup, and my testing setup.

I'm querying internally to get wider coverage and see if anyone
else is able to reproduce this.


Comment 2 Mike A. Harris 2002-02-01 00:41:36 UTC
Not able to reproduce this yet.  Here's what I've done:

1) startx as user (using KDE desktop)
2) open konsole, and then run xterm with no arguments
3) look at a man page, quit, run top
Results: bold shows up in blue - white background

su to root, run xterm - same thing
su -  to root, run xterm - same thing
shutdown X, and do startx as root with a .xinitrc containing xterm - same thing.

In all cases, I get blue text for bold on a white background with black
writing.

Have you modified any xterm resources?

Comment 3 Mike A. Harris 2002-02-01 00:52:29 UTC
Yeah, I did some more testing also logging into remote hosts..
still cant reproduce.  COuld you give me step by step instructions on
how to reproduce this, and attach your XF86Config-4 and X server logs
as file attachments using the link below (do not cut and paste please).

Comment 4 Mike A. Harris 2002-02-09 19:24:44 UTC
Still cant reproduce.


Note You need to log in before you can comment on or make changes to this bug.