Bug 57941 - rpm fails to build samba 2.2.2-8 from src.rpm for i686
Summary: rpm fails to build samba 2.2.2-8 from src.rpm for i686
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: samba   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-02 21:17 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-02 21:17:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-01-02 21:17:41 UTC
I'm not sure if this is a bug in samba or rpm but I suspect that the
problem is in the spec file.

When I attempt to build samba 2.2.2-8 from a spec file for target=i686, the
build fails due to missing files in a glob, while working on samba-common.
 The last directory in the glob is codepages.  I've only tried building
i686 and the default.  This may be a problem for other archs as well.


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh samba-2.2.2-8.src.rpm
2.rpm -ba --target=i686 samba.spec
3.
	

Actual Results:  rpm fails to build packages due to missing files.

Expected Results:  It should have build the packages.

Comment 1 Trond Eivind Glomsrxd 2002-01-08 23:40:01 UTC
rpm-4.0.3-1.03

"rpmbuild --target=i686 -ba samba.spec" works fine for me with samba-2.2.2-8

Comment 2 Need Real Name 2002-01-14 19:53:35 UTC
Found problem.  I was under assumption that processor was PII or better.  Turned
out to be a vanilla Pentium, hence the problem building for i686.  Sorry for 
the disturbance.


Note You need to log in before you can comment on or make changes to this bug.