This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57943 - automake has bug WRT lisp makefiles
automake has bug WRT lisp makefiles
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: automake (Show other bugs)
7.2
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-02 17:10 EST by Chris Adams
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 01:34:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix lisp.am bug (633 bytes, patch)
2002-01-02 17:10 EST, Chris Adams
no flags Details | Diff

  None (edit)
Description Chris Adams 2002-01-02 17:10:19 EST
automake will generate a bogus Makefile.in when using lisp (the gettext
package is one example).  It puts an @ in the Makefile.in so make won't
quit on an error, but it puts it in the middle of a shell expression (so
the shell barfs on an extraneous @).  It looks like someone created lisp.am
by copying another .am file and didn't take this out.

The patch is easy (and will be attached).
Comment 1 Chris Adams 2002-01-02 17:10:49 EST
Created attachment 41653 [details]
Patch to fix lisp.am bug
Comment 2 Tom Tromey 2002-01-06 19:20:57 EST
FYI: this bug is fixed in the CVS automake.
We hope to do a bug-fix release soon.
This release will be in the 1.5 series.
The 1.4 series has ended.
(If Red Hat is sticking with 1.4 for a while, we can
work something out; this bug is also fixed on the 1.4 branch,
but the 1.4 branch can't be released as-is.)

Comment 3 Jens Petersen 2002-01-07 01:56:55 EST
Thanks.  This already seems fixed in automake-1.5, ie automake-1.5-1.  (It was
also fixed in automake-1.4p5-3.)

Note You need to log in before you can comment on or make changes to this bug.