Bug 57949 - gcc reports internal error: insn does not satisfy its constraints
Summary: gcc reports internal error: insn does not satisfy its constraints
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://artax.karlin.mff.cuni.cz/~miku...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-03 00:20 UTC by Mikulas Patocka
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 18:58:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikulas Patocka 2002-01-03 00:20:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16 i586; Nav)

Description of problem:
when compiling quake2 (could be downloaded at
ftp://ftp.idsoftware.com/idstuff/source/q2source-3.21.zip), gcc gives an
internal error. I put preprocessed files (original and simplified) at the
specified url.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download file from http://artax.karlin.mff.cuni.cz/~mikulas/gcc-bug/
2. compile it with flags -mpentiumpro -O2 -fomit-frame-pointer -fPIC

	

Actual Results:  `-mpentiumpro' is deprecated. Use `-march=pentiumpro' or
`-mcpu=pentiumpro' instead.
../game/p_client.c: In function `ClientThink':
../game/p_client.c:92: Insn does not satisfy its constraints:
(insn:TI 386 156 387 (parallel[ 
            (set (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -276 [0xfffffeec])) 0)
                (fix:SI (reg:SF 8 st(0))))
            (clobber (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -272 [0xfffffef0])) 0))
            (clobber (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -276 [0xfffffeec])) 0))
            (clobber (reg:SI 6 ebp))
        ] ) 111 {*fix_truncsi_1} (insn_list 156 (nil))
    (expr_list:REG_DEAD (reg:SF 8 st(0))
        (nil)))
../game/p_client.c:92: Internal compiler error in final_scan_insn, at
final.c:2876
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
`-mpentiumpro' is deprecated. Use `-march=pentiumpro' or `-mcpu=pentiumpro'
instead.
../game/p_client.c: In function `ClientThink':
../game/p_client.c:92: Insn does not satisfy its constraints:
(insn:TI 386 156 387 (parallel[ 
            (set (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -276 [0xfffffeec])) 0)
                (fix:SI (reg:SF 8 st(0))))
            (clobber (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -272 [0xfffffef0])) 0))
            (clobber (mem:SI (plus:SI (reg/f:SI 6 ebp)
                        (const_int -276 [0xfffffeec])) 0))
            (clobber (reg:SI 6 ebp))
        ] ) 111 {*fix_truncsi_1} (insn_list 156 (nil))
    (expr_list:REG_DEAD (reg:SF 8 st(0))
        (nil)))
../game/p_client.c:92: Internal compiler error in final_scan_insn, at
final.c:2876
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  it should compile the file

Additional info:

the bug was reproduced with
gcc-2.96-84
gcc-2.96-96
gcc-3.0.2-3

Comment 1 rodrigc 2002-01-28 02:49:13 UTC
This problem looks like it is fixed in gcc 3.0.3 and higher.


Note You need to log in before you can comment on or make changes to this bug.