Bug 579511 - When virtio is enabled in the bios X-windows displays a colourful line pattern and freezes there
Summary: When virtio is enabled in the bios X-windows displays a colourful line patter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-05 16:17 UTC by John (J5) Palmieri
Modified: 2018-04-11 08:43 UTC (History)
6 users (show)

Fixed In Version: kernel-2.6.33.2-57.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-25 13:56:29 UTC
Type: ---


Attachments (Terms of Use)
Current successful Xorg log file (404.44 KB, text/plain)
2010-04-05 16:19 UTC, John (J5) Palmieri
no flags Details

Description John (J5) Palmieri 2010-04-05 16:17:22 UTC
Description of problem:

My new Lenovo t410s with the intel driver (Intel(R) Arrandale chip) has bios options to enable vitrualization and virtualized io.  Enabling virtualization work fine but if I also enable the virtio X never brings up the desktop on the host os.  It only shows a colourful line pattern.  Sometimes I can see the mouse move as a roughly 32x32 block of the same line pattern.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.10.0-4.fc13.x86_64

How reproducible:

All the time when bios option is enabled

Steps to Reproduce:
1. boot bios
2. select configure/cpu/virtualized io option
3. enable it
4. save bios options and boot into a X session
  
Actual results:

Colourful line pattern shows on screen.  A lot of disk activity.  Nothing else happens.

Expected results:

Loads up my desktop.
Additional info:

Comment 1 John (J5) Palmieri 2010-04-05 16:19:38 UTC
Created attachment 404506 [details]
Current successful Xorg log file

I can try to reboot with the option turned on and see if it writes out a log file.  Let me know what you need me to do to debug this issue.

Comment 2 Volker Braun 2010-04-06 22:56:01 UTC
I got the same result (colorful vertical stripes) with Fedora 12 x86_64 DVD iso on my T410s and selecting "basic video install". Default installation just hangs at a black screen.

Intel(R) VT-d Feature = Disabled fixes it for me, too.

Comment 3 Matěj Cepl 2010-04-08 07:40:44 UTC
Please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the
bugzilla file attachment link above.

However, my gut feeling is that there is something weird going on in the lower
levels of the software stack. If I won't see anything interesting in the logs,
I will most likely reassign the bug to kernel component.

Thanks in advance.

Comment 4 Matěj Cepl 2010-04-08 07:42:33 UTC
(In reply to comment #2)
> I got the same result (colorful vertical stripes) with Fedora 12 x86_64 DVD iso
> on my T410s and selecting "basic video install". Default installation just
> hangs at a black screen.
> 
> Intel(R) VT-d Feature = Disabled fixes it for me, too.    

Please attach the same information as requested in the comment 3, please.

Thank you

Comment 5 John (J5) Palmieri 2010-04-09 16:15:58 UTC
I've been trying to get the info requested but it hard freezes so I can't even ssh in.  Attached is my var/log/messages (Xorg already attached).  

I can confirm this is a modesetting issue though.  Booting into runlevel 3 gets similar hang (in the default runlevel the pattern shifts a bit when X loads and for a couple of seconds I can move the mouse around).  Running with nomodeset kernel option gets me to a command line.

Comment 6 Adam Williamson 2010-04-16 18:20:37 UTC
A new version of the Intel driver, xorg-x11-drv-intel-2.11.0-1.fc13, has just been added: https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.11.0-1.fc13 . Can you please test with this version and see if the bug is reproducible? If you have an installed Fedora 13, you can download and install the driver from the Koji link. If you are testing with live images, the nightly live images from 2010-04-17 (or possibly 2010-04-18) onwards should include this version: http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/ . This comment is being added to all open Fedora 13 intel bugs, please ignore if it does not make sense in the context of your bug.

Comment 7 Volker Braun 2010-04-17 02:44:18 UTC
With xorg-x11-drv-intel-2.11.0-1.fc13 I still get the same colorful vertical stripes. But I get to eventually see and move around a (corrupted) mouse pointer, it appears as a slightly lighter square of the same vertical stripes. 

One can probably SSH in at that point, but I do not have a second computer available at the moment.

Comment 8 Fedora Update System 2010-04-20 14:14:57 UTC
kernel-2.6.33.2-57.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.2-57.fc13

Comment 9 Fedora Update System 2010-04-21 02:19:25 UTC
kernel-2.6.33.2-57.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.33.2-57.fc13

Comment 10 John (J5) Palmieri 2010-04-21 14:50:03 UTC
New kernel works for me.  Waiting for Volker to confirm then we can close.  Kernel team rocks.  Thanks.

Comment 11 Volker Braun 2010-04-21 15:57:17 UTC
With the new kernel (kernel-2.6.33.2-57.fc13.x86_64) this works for me, too!

Comment 12 Adam Williamson 2010-04-21 16:45:36 UTC
Great. If you guys can leave +1s in Bodhi too that'd be awesome.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Fedora Update System 2010-04-25 13:55:46 UTC
kernel-2.6.33.2-57.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.