Bug 57952 - Intolerable time outs on laptops with built-in but unconnected ethernet ports
Intolerable time outs on laptops with built-in but unconnected ethernet ports
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-02 23:33 EST by Rob Gerth
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Gerth 2002-01-02 23:33:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16 i686)

Description of problem:
When automatically bringing up an ethernet interface, the current scripts
assume the port to be connected. This is a problem for laptops
such as the ThinkPad T21 which has ethernet built-in if they are not
connected (rather common): during boot or resume there is a 2-3 minute
delay because dhcpd has to time out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. remove the ethernet cable from your system
2. ifdown eth0; ifup eth0
3.
	

Actual Results:  dhcp time out

Expected Results:  ifup tries to detect a link beat first and exit 0's if
there is none

Additional info:

To fix this bug:
mii-diag.c from www.scyld.com/diag is a GPLed program to detect link
status. Assuming this to be in /sbin, add the following to /sbin/ifup:
   if [ "${DEVICETYPE}" = "eth" -a -x /sbin/mii-diag ]; then 
      /sbin/mii-diag -s ${DEVICE} > /dev/null 
      if [ $? != 0 ]; then 
         echo "no link beat found: ${DEVICE} seems not connected"
         exit 0 
      fi 
   fi 
after the line
   echo -n $"Determining IP information for ${DEVICE}..."
Comment 1 Bill Nottingham 2005-09-29 15:29:54 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.