Bug 57953 - Klipper doesn't open the action menu under certain circumstances
Klipper doesn't open the action menu under certain circumstances
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-03 01:20 EST by A. Miklas
Modified: 2006-10-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Miklas 2002-01-03 01:20:44 EST
Description of Problem:
klipper does not open the "actions menu" when an item is selected from the 
history menu even if the "replay actions on an item selected from history" 
option is enabled if the window that currently has the focus is of a type listed 
in "disable actions for windows of type WM_CLASS".

Version-Release number of selected component (if applicable):
kdebase-2.2-12

How Reproducible:
Always

Steps to Reproduce:
1. Enable "replay actions on an item selected from history" -- it isn't on by 
default.
2. Highlight a URL in Konqueror.  No "action menu" will be opened by default 
(because Konqueror is listed in the exlude list).
3. Click on the URL in the history list.
4. The action menu should have opened, but because Konqueror was had 
the focus just before klipper was clicked, klipper doesn't open the action 
menu.
5. Make any other window active.  Click the same item in the history.  Now 
the action menu will appear.

Actual Results:
The action menu is not opened.

Expected Results:
Since the item is being selected from klipper's history, klipper should 
probably not be sensitive to the window that currently has the focus.
Therefore, the action menu should appear regardless of whether the 
previously selected window is on the disable list.

Additional Information:
Comment 1 Petr Rockai 2005-08-10 12:10:08 EDT
Please retry with current version of Fedora Core. Unless you followup on this  
bug, it will be considered fixed and will be closed at some point... Thank you  
for your time. 
Comment 2 Bill Nottingham 2006-10-18 12:37:19 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.