Bug 57970 - Upgrade 7.1->7.2 leaves kde broken, undefined symbol libs
Upgrade 7.1->7.2 leaves kde broken, undefined symbol libs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-03 15:14 EST by Bryce Nesbitt
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 05:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2002-01-03 15:14:14 EST
After upgrading from 7.1 to 7.2 kde is broken:

HardHat:bryce> kcharselect 
kcharselect: relocation error: /usr/lib/libksycoca.so.3: undefined symbol:
sizeHint__C11KDialogBase
HardHat:bryce> konqueror 
konqueror: relocation error: /usr/lib/libkssl.so.2: undefined symbol:
polish__7KDialog
HardHat:bryce> kword 
kword: relocation error: /usr/lib/libkssl.so.2: undefined symbol:
polish__7KDialog

(Those were all stared from gnome).  "kpoker" works, however.  Whoo hoo.
Nothing weird showed up in the  upgrade log.  Everything looks like it's
installed right:

HardHat:bryce> rpm -q -f /usr/lib/libkssl.so.2
kdelibs-2.2-11
HardHat:bryce> rpm -q qt
qt-2.3.2-1

Whazzup?
Comment 1 Bernhard Rosenkraenzer 2002-01-04 08:46:55 EST
No problem whatsoever here.
Since you're not on a stock 7.1->7.2 system (we never shipped qt 2.3.2), this is
likely to be a local problem.

By any chance, did you rebuild kdelibs with a compiler other than gcc 2.96?

Does rpm -Uvh --force /wherever/kdelibs* help?
Comment 2 Bryce Nesbitt 2002-01-04 10:40:48 EST
You're sure you never shipped 2.3.2?  It was at least packaged:

Name        : qt-devel                     Relocations: /usr/lib/qt-2.3.2 
Version     : 2.3.2                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Tue 06 Nov 2001 07:20:41
EST
Install date: Fri 30 Nov 2001 10:16:47 EST      Build Host:
stripples.devel.redhat.com
Group       : Development/Libraries         Source RPM: qt-2.3.2-1.src.rpm
Size        : 22909903                         License: GPL/QPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.troll.no/
Summary     : Development files and documentation for the Qt GUI toolkit.
Description :
The qt-devel package contains the files necessary to develop
applications using the Qt GUI toolkit: the header files, the Qt meta
object compiler, the man pages, the HTML documentation, and example
programs.


I upgraded QT at some point.  After force downgrading qt:
	rpm -Uvh --force qt-*
	rpm -Uvh --force kdelibs-*
I get the same thing.
Comment 3 Ngo Than 2004-09-14 05:02:45 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "CURRENTRELEASE" for now.

Note You need to log in before you can comment on or make changes to this bug.