Bug 579786 - large doc fails to build: potential infinite template recursion
large doc fails to build: potential infinite template recursion
Status: CLOSED DUPLICATE of bug 577068
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-06 11:07 EDT by Paul Morgan
Modified: 2010-11-23 23:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 19:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morgan 2010-04-06 11:07:39 EDT
Description of problem:
building large doc fails with:
> runtime error: file  
> file:///usr/share/sgml/docbook/xsl-stylesheets-1.75.2/fo/verbatim.xsl 
> line 413 element param
> xsltApplyXSLTTemplate: A potential infinite template recursion was detected.
> You can adjust xsltMaxDepth (--maxdepth) in order to raise the 
> maximum number of nested template calls and variables/params 
> (currently set to 1000).



Version-Release number of selected component (if applicable):
1.6.1 or higher


How reproducible:
always on large doc; on publican-list Josh Kayse reports that he
tried multiple brands

Steps to Reproduce:
1. successfully build large doc with previous version
2. do not modify document
3. fail to build using current publican version
  
Actual results:
fails to build with error shown above

Expected results:
doc should build

Additional info:

Josh Kayse also experienced error and provided work-around:
"Changing line 704 of  
/usr/lib/perl5/vendor_perl/5.10.0/Publican/Builder.pm from 1000 to 
10000 allows me to build my 400+ page document.

I don't know that it is the correct action, but it will work for me for now."

Josh's workaround works for me, too, on my 335-page doc.

Note that `rpm -ql publican | xargs grep xsltMaxDepth' fails to show anything relevant.
Comment 1 Jeff Fearn 2010-04-06 19:27:21 EDT
This is actually caused by the same issue as 577068
Comment 2 Jeff Fearn 2010-04-06 19:27:35 EDT

*** This bug has been marked as a duplicate of bug 577068 ***

Note You need to log in before you can comment on or make changes to this bug.