Bug 57999 - (GDTH)gdth Intel Raid Controller SRCU31L
(GDTH)gdth Intel Raid Controller SRCU31L
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-01-04 13:35 EST by Nuno Beirao
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nuno Beirao 2002-01-04 13:35:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
Installer can't find devices attached to SRCU31L raid controller

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot from Redhat 7.2 cdrom
2.Select any instalation type
3.Select any partition method

Actual Results:  Installer can't find any devices to install operating 

Expected Results:  Run partition program (Diskdruid)

Additional info:

Machine Specs:
2x Intel Xeon 1Gz
Intel SBT2 Motherboard (updated with all firmwares and bios)
Intel Raid Controller SRCU31L (updated with firmware stack 6.xx)
2x Quantum SCSI HD 36Gb


the installer detects the Intel reaid controller and tries to load the 
GDTH driver and gives no error. If I do ALT-F3 to switch to another 
console I see an error like this:

* going to insmod gdth.o (path is NULL)
/tmp/gdth.o: init_module: %m
Hint: insmod errors can be caused by incorrect module parameters, 
including invalid IO or IRQ parameters

Then when the installation program asks to select a partition method it 
opens an error window saying:

"An error has ocurred - no valid devices were found on which to create 
new filesystems."

On Intel's site there's a driver disk for Redhat 7.1 but it doesn't work, 
it gives the same error.

If I switch to the shell using ALT-F2 and go to /proc/scsi there ins't 
any directory named gdth, only a file name scsi.

NOTE: I'm using the new 6.xx software stack on the SRCU31L which is 
compatible with the ICP-VORTEX cards. The old 5.xx software stack used 
the I2O driver on Linux.
I tried to install on two identical machines and got the same results, so 
I think it's not an hardware problem.

Thanks for your support.
Comment 1 Jason Sauve 2003-09-16 14:02:00 EDT
This is well documented on Intel's website. You need to use the Driver Disk 
for RH 7.2. Go to intel's support site to read more.
Comment 2 Bugzilla owner 2004-09-30 11:39:19 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.