Bug 58007 - rpmq going to sleep on select()
rpmq going to sleep on select()
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-04 20:26 EST by Bill Crawford
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 17:39:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace after attaching gdb to hung rpmq process. (1.65 KB, text/plain)
2002-01-04 20:28 EST, Bill Crawford
no flags Details

  None (edit)
Description Bill Crawford 2002-01-04 20:26:38 EST
Description of Problem:
Inadvertently running a "rpm -q something-x.y-z" whilst /etc/cron.daily/rpm
was running appears to have caused the latter rpmq process to hang.  A
backtrace will be attached in a moment.

Version-Release number of selected component (if applicable):
[bill@desktop bill]$ rpm -q rpm
rpm-4.0.4-0.4

Bizarrely that rpm -q ran fine whilst the other process was sat there with
gdb attached ... *shrug*

I'm assuming there is something specific about the state of my rpm database
(and others that have had this problem) that isn't there in yours, so you
can't reproduce it.  I'm quite happy as I've said before for you to look at
this rpm database to see if you can find the problem(s).  As far as I'm
concerned, though, even if the problem *has* been caused by some kind of
corruption in the past, I have run --rebuilddb *several* times, to no
avail; this, and the problem I have with rpm -qf hanging, are still
appearing.
Comment 1 Bill Crawford 2002-01-04 20:28:57 EST
Created attachment 41833 [details]
Backtrace after attaching gdb to hung rpmq process.
Comment 2 Jeff Johnson 2002-01-07 16:27:23 EST
Try
	rm -f /var/lib/rpm/__db*
Comment 3 Bill Crawford 2002-01-07 17:36:43 EST
Yeah, sure ... but why is the process hanging like that?  It *appears* to have
been triggered by two processes trying to access the database at the same time,
sure ... but they're both read-only accesses, if they're queries, aren't they? 
Why does that end up hanging?

Can't we just get rid of these __db* files?
Comment 4 Bill Crawford 2002-01-07 17:38:58 EST
And closing bugs as "WORKSFORME" when it plainly isn't working right for other
people really isn't an answer, please consider that some bugs only affect a
small number of people, and I assure you they have been reproducible and
repeatable.
Comment 5 Jeff Johnson 2002-01-08 12:48:30 EST
Short answer:  The __db files are gonna be necessary to support
concurrent database access so that, say, rpm installs can be run
from %post scriptlets (i.e. a package of packages). No they cannot
be eliminated.

And I have a limited number of resolutions to choose from, WORKSFORME
is closest IMHO.
Comment 6 Bill Crawford 2002-01-08 13:18:24 EST
Well, OK ... cluster packages would be nice.

But this is still a bug, as is the other problem I reported.

Note You need to log in before you can comment on or make changes to this bug.