Bug 580085 - LVMError: lvactivate failed for lv_root: Running... lvm lvchange -a y VolGroup/lv_root
LVMError: lvactivate failed for lv_root: Running... lvm lvchange -a y VolGrou...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
anaconda_trace_hash:4e6ccc75b3bc41354...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 09:02 EDT by James Laska
Modified: 2013-09-02 02:47 EDT (History)
14 users (show)

See Also:
Fixed In Version: lvm2-2.02.73-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 05:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (111.42 KB, text/plain)
2010-04-07 09:02 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-04-07 09:02:34 EDT
The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 408, in lvactivate
    raise LVMError("lvactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2289, in setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1439, in handleUdevLVMPVFormat
    lv.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1784, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1278, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1936, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 377, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 110, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 659, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1188, in <module>
    anaconda.intf.run(anaconda)
LVMError: lvactivate failed for lv_root: Running... lvm lvchange -a y VolGroup/lv_root
Comment 1 James Laska 2010-04-07 09:02:38 EDT
Created attachment 404946 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-04-07 09:04:05 EDT
13:01:59,013 WARN kernel:lvm invoked oom-killer: gfp_mask=0x201da, order=0, oom_adj=0
Comment 3 James Laska 2010-04-07 09:06:16 EDT
This is just another case where 512M is not enough on an x86_64 system when performing LVM operations.
Comment 4 Peter Rajnoha 2010-05-10 06:17:41 EDT
From the log:
13:01:59,013 WARN kernel:lvm invoked oom-killer: gfp_mask=0x201da, order=0, oom_adj=0
...
13:01:59,014 WARN kernel: [<ffffffff810f782e>] sys_mlockall+0x96/0xc2
13:01:59,014 WARN kernel: [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b

Yes, it seems to be another case with known mlockall problem. A few patches have already been sent upstream and it should be included in next F-13 release. Setting to POST then. If the bug appears again, please, reopen this report.
Comment 5 Fedora Update System 2010-08-26 14:46:25 EDT
lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13
Comment 6 Fedora Update System 2010-08-30 14:29:46 EDT
lvm2-2.02.73-2.fc13, udisks-1.0.1-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lvm2 udisks'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13
Comment 7 Fedora Update System 2010-09-11 05:00:34 EDT
lvm2-2.02.73-2.fc13, udisks-1.0.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.