Bug 580156 - [abrt] crash in bind-utils-32:9.6.2-3.P1.fc12: Process /usr/bin/dig was killed by signal 11 (SIGSEGV)
[abrt] crash in bind-utils-32:9.6.2-3.P1.fc12: Process /usr/bin/dig was kille...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:3a10621b37c3f2f9a6cb1738754...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 11:28 EDT by Locque
Modified: 2013-04-30 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 11:20:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.25 KB, text/plain)
2010-04-07 11:28 EDT, Locque
no flags Details

  None (edit)
Description Locque 2010-04-07 11:28:15 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: dig tsm.lc.ca.gov
comment: Just tried to run dig on a domain and got a core dump
component: bind
executable: /usr/bin/dig
kernel: 2.6.32.10-90.fc12.x86_64
package: bind-utils-32:9.6.2-3.P1.fc12
rating: 4
reason: Process /usr/bin/dig was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Simply opened command line
2. ran `dig google.com`
3. core dumped!
Comment 1 Locque 2010-04-07 11:28:16 EDT
Created attachment 404998 [details]
File: backtrace
Comment 2 Locque 2010-04-16 10:04:36 EDT

How to reproduce
-----
1. Open terminal
2. Run 'dig <hostname>'
3. Segmentation Fault


Comment
-----
I don't remember when this broke. Used to work fine, but now I get a seg fault everytime. I've tried running as root and still get the error. Also tried reinstalling bind-utils but that didn't change anything
Comment 3 Adam Tkac 2010-05-07 08:04:13 EDT
It seems your /usr/lib64/libisc.so* got corrupted some way. Would it be possible to execute `rpm -qV bind-libs` and post output here, please?
Comment 4 Locque 2010-05-07 10:21:59 EDT
Here is the output you've requested:

rpm -qV bind-libs
..5......    /usr/lib64/libisc.so.50.2.1
Comment 5 Adam Tkac 2010-05-10 05:12:17 EDT
(In reply to comment #4)
> Here is the output you've requested:
> 
> rpm -qV bind-libs
> ..5......    /usr/lib64/libisc.so.50.2.1    

It means your and original libisc differ in MD5 sums. Please try to reinstall bind-libs and report if the problem still exists.
Comment 6 Locque 2010-05-12 11:20:17 EDT
Thanks for your help... That fixed it

yum reinstall bind-libs

Now dig works without a core dump

Note You need to log in before you can comment on or make changes to this bug.