Bug 58018 - Strange "proportional" fonts
Strange "proportional" fonts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: urw-fonts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-05 19:28 EST by Michal Jaegermann
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 10:30:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-01-05 19:28:25 EST
Description of Problem:

Looking at /usr/share/fonts/default/Type1/fonts.scale one can see there:

n022003l.pfb -URW-Nimbus Mono L-medium-r-normal--0-0-0-0-p-0-iso8859-1
n022003l.pfb -URW-Nimbus Mono L-medium-r-normal--0-0-0-0-p-0-iso8859-2
n022004l.pfb -URW-Nimbus Mono L-bold-r-normal--0-0-0-0-p-0-iso8859-1
n022004l.pfb -URW-Nimbus Mono L-bold-r-normal--0-0-0-0-p-0-iso8859-2
n022023l.pfb -URW-Nimbus Mono L-medium-o-normal--0-0-0-0-p-0-iso8859-1
n022023l.pfb -URW-Nimbus Mono L-medium-o-normal--0-0-0-0-p-0-iso8859-2
n022024l.pfb -URW-Nimbus Mono L-bold-o-normal--0-0-0-0-p-0-iso8859-1
n022024l.pfb -URW-Nimbus Mono L-bold-o-normal--0-0-0-0-p-0-iso8859-2
n022003l.pfb -URW-Courier-medium-r-normal--0-0-0-0-p-0-iso8859-1
n022003l.pfb -URW-Courier-medium-r-normal--0-0-0-0-p-0-iso8859-2
n022004l.pfb -URW-Courier-bold-r-normal--0-0-0-0-p-0-iso8859-1
n022004l.pfb -URW-Courier-bold-r-normal--0-0-0-0-p-0-iso8859-2
n022023l.pfb -URW-Courier-medium-o-normal--0-0-0-0-p-0-iso8859-1
n022023l.pfb -URW-Courier-medium-o-normal--0-0-0-0-p-0-iso8859-2
n022024l.pfb -URW-Courier-bold-o-normal--0-0-0-0-p-0-iso8859-1
n022024l.pfb -URW-Courier-bold-o-normal--0-0-0-0-p-0-iso8859-2

In other words we have here an example of a proportional Courier font
which is rather unusual. :-)  Nimbus Mono fonts are remarkably similar
but this is not so surprising if one will notice that these are really
the same files with obvious implications for glyphs.

In reality all of the above are truly monospaced fonts which can be
trivially seen if they are used as text fonts in an editor like emacs
or vi.  I know that all pfb files above have
/isFixedPitch false def
but this seems to be an editing error in URW fonts and there is
hardly a reason to propagate it further. All '-p-' above should
be '-m-'.  A half-hearted attempt to fix that with the help of
'fonts.alias', done for Courier, does not seem to work if 
"Nimbus Mono L" names are used (blanks in names?).  Changing
fonts.scale, and fonts.dir, without touching fonts works like it should.

BTW - a name like "Mono L" is not the luckiest one; after loading
in gfontsel a lower case sans-serif fonts is used to display names
and "Mono L" does not differ from "mono 1" ('one' not 'ell').
Comment 1 Ngo Than 2002-06-12 07:32:58 EDT
i hope it's fixed in urw-fonts-2.0-19.

Note You need to log in before you can comment on or make changes to this bug.