Bug 580230 - Blender update needed
Summary: Blender update needed
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: blender
Version: el5
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-07 19:07 UTC by Aaron
Modified: 2010-05-09 19:43 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-07 17:46:55 UTC


Attachments (Terms of Use)

Description Aaron 2010-04-07 19:07:11 UTC
Description of problem:
Blender 2.45 does not work well with the physics or particle systems created in 2.49b.  2.49b is needed for a school project.

Version-Release number of selected component (if applicable):
2.45

How reproducible:
Very

Steps to Reproduce:
1. Open a file with physics objects linked to physics proxies, a particle system implemented, or even a limited bit of the frame set to render
2. Try to run the game engine, render the scene, or change the render viewport, respectively
  
Actual results:
Crash, blank render, and strange GUI performance, respectively

Expected results:
Correct physics, correct render, and functional GUI


Additional info:

All these problems have been fixed in 2.49b. I very urgently need the package updated for a time-sensitive project.

Comment 1 Fedora Update System 2010-04-09 14:59:27 UTC
blender-2.49b-7.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/blender-2.49b-7.el5

Comment 2 Jochen Schmitt 2010-04-09 15:03:20 UTC
Thank you for reporting this bug, I have created an updated release of blender for EPEL-5. You should be able to download it from the updates-testing repository with

# yum --enablerepo updates-testing blender

Please lets me know, if this release fullfill your requirements

Comment 3 Fedora Update System 2010-04-09 22:56:57 UTC
blender-2.49b-7.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blender'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/blender-2.49b-7.el5

Comment 4 Aaron 2010-04-09 23:09:10 UTC
Thank you for putting the updated version in the repository. It's vital for a project I'm doing.  I'll comment back if I have any issues with it.

Thanks,
Aaron

Comment 5 Fedora Update System 2010-05-01 01:40:44 UTC
blender-2.49b-7.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blender'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/blender-2.49b-7.el5

Comment 6 Fedora Update System 2010-05-07 17:46:50 UTC
blender-2.49b-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Daniel Lyddy 2010-05-09 19:43:17 UTC
I am running into a dependency problem when trying to install blender.  The install is trying to get dejavu-fonts from rpmforge.  Should I be using a different repository for dejavu-fonts?

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package blender.i386 0:2.49b-7.el5 set to be updated
--> Processing Dependency: libImath.so.4 for package: blender
--> Processing Dependency: dejavu-fonts for package: blender
--> Processing Dependency: libIex.so.4 for package: blender
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: blender
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: blender
--> Processing Dependency: libHalf.so.4 for package: blender
--> Processing Dependency: libIlmImf.so.4 for package: blender
--> Processing Dependency: libstdc++.so.6 for package: blender
--> Running transaction check
---> Package dejavu-fonts.noarch 0:2.20-1.nodist.rf set to be updated
---> Package libstdc++.i386 0:4.1.2-46.el5_4.2 set to be updated
---> Package openexr.i386 0:1.4.0a-1.el5.rf set to be updated
--> Processing Conflict: dejavu-fonts conflicts fontconfig >= 2.3.0
--> Finished Dependency Resolution
dejavu-fonts-2.20-1.nodist.rf.noarch from rpmforge has depsolving problems
  --> dejavu-fonts conflicts with fontconfig
Error: dejavu-fonts conflicts with fontconfig
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Note You need to log in before you can comment on or make changes to this bug.