This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 580244 - s-c-firewall missing icon in gnome System->Administration menu
s-c-firewall missing icon in gnome System->Administration menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-07 15:44 EDT by James Laska
Modified: 2013-09-02 02:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-07 16:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-04-07 15:44:05 EDT
Description of problem:

s-c-firewall no longer has an icon on a default installed F-13-Beta-RC5 desktop.

Version-Release number of selected component (if applicable):
 * gnome-icon-theme-2.29.2-3.fc13.noarch
 * system-config-firewall-1.2.23-1.fc13.noarch

How reproducible:

Steps to Reproduce:
1. Install F-13-Beta-RC5, accepting all defaults (including default package set)
2. Boot installed system and login to desktop
3. Open menu System->Administration
  
Actual results:

The 'Firewall' application is missing an icon (see attached Screenshot).

Expected results:

The 'Firewall' application should have an icon.

Additional info: 

 * According to /usr/share/applications/system-config-firewall.desktop, the icon requested is ... 'Icon=preferences-system-firewall'.  

 * This file is only available in hicolor on the system, not in the gnome theme as seems to be the case with other icons in this menu.

   $ find /usr/share/icons/ -iname preferences-system-firewall.png 
  /usr/share/icons/hicolor/32x32/apps/preferences-system-firewall.png
  /usr/share/icons/hicolor/48x48/apps/preferences-system-firewall.png
  /usr/share/icons/hicolor/64x64/apps/preferences-system-firewall.png
  /usr/share/icons/hicolor/24x24/apps/preferences-system-firewall.png
  /usr/share/icons/hicolor/16x16/apps/preferences-system-firewall.png

  However, the windows icon appears in both 'HighContrastLargePrint' and 'gnome' themes

  $ find /usr/share/icons -iname preferences-system-windows.png 
  /usr/share/icons/HighContrastLargePrint/48x48/apps/preferences-system-windows.png
  /usr/share/icons/HighContrastLargePrintInverse/48x48/apps/preferences-system-windows.png
  /usr/share/icons/gnome/32x32/apps/preferences-system-windows.png
  /usr/share/icons/gnome/48x48/apps/preferences-system-windows.png
  /usr/share/icons/gnome/22x22/apps/preferences-system-windows.png
  /usr/share/icons/gnome/24x24/apps/preferences-system-windows.png
  /usr/share/icons/gnome/16x16/apps/preferences-system-windows.png
Comment 1 James Laska 2010-04-07 16:48:39 EDT
Updating to F-13 updates-testing resolved the reported issue.

 * gnome-icon-theme-2.30.0-2.fc13.noarch
 * system-config-firewall-1.2.24-1.fc13.noarch

Note You need to log in before you can comment on or make changes to this bug.