Bug 58026 - aic7899 - aic7xxx hang on install
aic7899 - aic7xxx hang on install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-06 05:58 EST by Malcolm
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 16:32:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Malcolm 2002-01-06 05:58:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Installer hang with aic7xxx with aic7899 SCSI controllers, tried noapic,
no_probe etc. 

problem "seems" different to existing aic7xxx installer hangs (but i might
be wrong)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot for fresh install, with CD1
2.type, linux, linux apic or linux aic=no_probe
3.Hang on loading aic7xxx .......
	

Actual Results:  VC4 - showed

loading scsi-mod module
SCSI subsystem driver revision: 1.00
loading sd_mod module
loading aic7xxx module
(scsi0) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 3/4/0
(scsi0) Wide channel A, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 396 instructions downloaded
(scsi1) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 3/4/1
(scsi1) Wide channel B, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 396 instructions downloaded
(scsi1:-1:-1:-1) spurious interrupt during configuration cleared
scsi0: Adaptec AHA274x/284x/294x (EISA/VLB/PCI-fast SCSI 5.2.4/5.2.0
        <Adaptec AIC-7899 Ultra 160/m SCSI host adapter
scsi1: Adaptec AHA274x/284x/294x (EISA/VLB/PCI-fast SCSI 5.2.4/5.2.0
        <Adaptec AIC-7899 Ultra 160/m SCSI host adapter


Expected Results:  Installer continued

Additional info:

The machine configuration (according to reporter) is

Motherboard: Supermicro P4DC6+ dual Xeon processor - Supermicro BIOS v.1.1
Award Medallion BIOS v.6.00PG
On-board Adaptec AIC-7899W SCSI controller - BIOS v.3.10S1
1 hard drive - Quantum Atlas 10KII-TY184J 18.4GB Ultra 160/LVD/SE

Will be doing some direct work with the box (1 of 20 for a web cluster) in
the next few days and may have more information
Comment 1 Shinya Narahara 2002-01-06 23:49:59 EST
We have same issue on our Pen4 machine. We guess the reason of this
is just SCSI BIOS version.  On 3.0 or later, the older aic7xxx.o couldn't
work correctly.

The situation is very similar, and it could be solved.
When installation, we must set the installer as "noprobe" mode, and use
scsi driver aic7xxx_mod.o instead of aic7xxx.o, however this might not
be complete installation because of some bug of aic7xxx_mod.o in redhat
original kernel.

We've changed it into new aic7xxx_mod.o(Ver 6.2.4) from 
        http://people.FreeBSD.org/~gibbs/linux/
This new one cleared our heat run and load test.

So we strongly recommend redhat to change aic7xxx_mod.o driver
into this new driver. Once redhat said aic7xxx_mod.o is not very
stable, but now we think it seems to be good enough.
Comment 2 Jeremy Katz 2002-01-07 00:54:26 EST
If you make an image with the drvblock.img on it and boot with 'linux noprobe'
and use F2 to use the other aic7xxx driver from the driver disk (should have a
description which includes aic7xxx_mod), does it work?
Comment 3 Shinya Narahara 2002-01-07 02:43:03 EST
It works *incompletely*. The original drvblock.img in redhat
7.2 CD has aic7xxx_mod.o(Ver 6.1.13) which is not latest(has some
issues on our heat run test).

We've not tried to make new drvblock.img which has aic7xxx_mod(6.2.4).
We made and tested kickstart file to overwrite aic7xxx_mod.o into 6.2.4.
It has been working currectly.

drvblock.img doesn't seem to be for installed kernel, it maybe for kernel
only during installation. If we could rewrite aic7xxx_mod.o for every of
kernel-2.4.7-10BOOT, kernel-2.4.7-10 and kernel-smp-2.4.7-10, it must
work perfectly.
Comment 4 Need Real Name 2002-01-08 22:02:08 EST
Same here - total hang with RedHat 7.2

Motherboard: Supermicro P4DC6+ dual Xeon 1.7 ghz processor
Supermicro BIOS v.1.1
Award Medallion BIOS v.6.00PG
On-board Adaptec AIC-7899W SCSI controller - BIOS v.3.10S1

Comment 5 Shinya Narahara 2002-01-09 01:16:35 EST
We confirmed that we can install RH7.1 and RH7.2 into these BAD hardwares.

1. boot installer with paramater "noprobe".
2. make installer load "aic7xxx_mod.o" manually.
3. do normal installation.
4. at the last screen of installer, you must do something.
    4.1) press Alt+Ctrl+F2 (and go into command line).
    4.2) chroot /mnt/sysimage.
    4.3) vi /etc/modules.conf (and remove any aic7xxx line, below).
    4.4) make initrd again (for RH7.2 UP, do "mkinitrd -f /boot/initrd-2.4.7-10.img 2.4.7-10").
    4.5) do lilo again.
5. Alt+Ctrl+F7 and finish installation.

The RedHat Installer adds scsi host adapter lines into modules.conf like below:

alias scsi_hostadapter aic7xxx_mod    # This is added because of manual select.
alias scsi_hostadapter1 aic7xxx         # This is added by installer automatically.
alias scsi_hostadapter2 aic7xxx         # This is also added by him.

and making initrd and doing lilo are done accoding to this modules.conf.
This is why the redhat linux fail to boot on first boot time however
the installation was succeeded when we specify to use aic7xxx_mod,
two drivers(aic7xxx_mod and aic7xxx) is loaded on its boot time and
have some conflict.

So, we must remove these line, make initrd and do lilo again DURING
INSTALLATION.

We guess this is installer bug. for the machine which has two IntelEtherExpress100,
if we do noprobe install and set e100 driver for them, installer adds a line below:
alias eth1 eepro100
into /etc/modules.conf. However, we know this is not so easy to fix, because
many drivers have a possibility to have conflicts each other...
Comment 6 Jeremy Katz 2002-01-21 20:38:56 EST
Fixed in CVS and update disk at http://people.redhat.com/katzj/7.2updates.img
Comment 7 Need Real Name 2002-01-21 23:28:55 EST
alright I'm an idiot - the 7.2updates.img link isn't working ... any others?
Comment 8 Jeremy Katz 2002-01-21 23:38:51 EST
Sorry, I can't type.. http://people.redhat.com/katzj/7.2-updates.img  (and it's
fixed in that it fixes the handling of initrd creation when you use a driver
disk; you'll still need to use the driver disk)
Comment 9 Paul Wouters 2002-02-10 12:57:39 EST
On an dual cpu Asus P2B board with aic7xxx I had similar problems. Though for
me the install worked fine without errors, but no initrd is made or installed
and the resulting machine can't boot bcause it has no aic7xxx support. When
booting with a custom kernel, I found that other essential things were also
missing from the install. Most importantly, rpm didn't get installed,
renderig the machine quite useless.

Note You need to log in before you can comment on or make changes to this bug.