Bug 580285 - [abrt] crash in OutWW8_SwTextGrid
Summary: [abrt] crash in OutWW8_SwTextGrid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2e1420f6d180385c60f39af5abf...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-07 21:27 UTC by Sergey Kurtsev
Modified: 2010-06-08 13:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-08 13:19:00 UTC


Attachments (Terms of Use)
File: backtrace (59.76 KB, text/plain)
2010-04-07 21:27 UTC, Sergey Kurtsev
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 102844 None None None Never

Description Sergey Kurtsev 2010-04-07 21:27:19 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///home/sk/%D0%94%D0%BE%D0%BA%D1%83%D0%BC%D0%B5%D0%BD%D1%82%D1%8B/%D0%9A%D0%BB%D0%B8%D0%B5%D0%BD%D1%82%D1%8B/%D0%A1%D0%B0%D0%B9%D1%82%20%D0%BA%D0%B2%D0%B0%D1%80%D1%82%D0%B8%D1%80/%D0%A2%D0%97%20%D0%A1%D0%B0%D0%B9%D1%82%D0%B0.doc
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.32.9-70.fc12.i686.PAE
package: openoffice.org-writer-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Sergey Kurtsev 2010-04-07 21:27:23 UTC
Created attachment 405110 [details]
File: backtrace

Comment 2 David Tardon 2010-04-08 05:39:34 UTC
Crash on export to doc. Can you reproduce it with the same input file and the same modifications to it? If yes, can you attach that file here together with a description about how to get to the 'bad' state? (If the file is not to be made publicly accessible, you can mail it either to caolan or to me.)

Comment 3 David Tardon 2010-04-08 06:36:04 UTC
It looks like the first slot in the to-be-exported formats' list hadn't been initialized; in other words there was no RES_POOLCOLL_STANDARD format (the 'Default' format) in the document. That surely is weird...

Comment 4 Caolan McNamara 2010-04-09 12:59:46 UTC
I believe this is http://qa.openoffice.org/issues/show_bug.cgi?id=102844

Fix checked in, will be in >= 3.1.1-19.29 if there is another update for F-12

Comment 5 Fedora Update System 2010-05-08 07:56:38 UTC
openoffice.org-3.1.1-19.30.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.30.fc12

Comment 6 Fedora Update System 2010-05-10 17:07:33 UTC
openoffice.org-3.1.1-19.30.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.30.fc12


Note You need to log in before you can comment on or make changes to this bug.