Bug 58063 - Low robustness when installing LILO
Low robustness when installing LILO
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-07 11:49 EST by Juan Jose Amor
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 19:44:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Jose Amor 2002-01-07 11:49:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [es] (X11; U; Linux 2.2.20BS1 i586)

Description of problem:
When installing LILO, anaconda is not robust. May crash in a scenary where it
may not (trivially) be created the /etc/lilo.conf file.

For example, when I upgraded Redhat linux from 7.1 to 7.2, if /etc/lilo.conf
is a symbolic link to /boot/lilo.conf, anaconda does not check why it can not
create
/etc/lilo.conf, anaconda simply halts the installation process.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a Redhat Linux release, with LILO as boot loader.
2. Move /etc/lilo.conf to another place and then symlink to this file from /etc
3. Upgrade Redhat Linux and choose LILO install. anaconda will crash when
trying to create lilo.conf file.
	

Additional info:
Comment 1 Jeremy Katz 2002-01-07 12:23:31 EST
It should be moving the old lilo.conf (even if a symlink) to be
lilo.conf.rpmsave;  if you're getting a crash, the full backtrace would be very
handy.
Comment 2 Juan Jose Amor 2002-01-07 13:44:11 EST
I've not a python backtrace because it occurred during installation phase and I
did not saved it.

However, I remember anaconda stderr said "cannot open /etc/lilo.conf for
writing", and
when I booted my system again with a diskette, both the symlink and the "real"
lilo.conf files
are untouched.
Comment 3 Brent Fox 2002-01-17 10:43:04 EST
katzj: do you think lilo.conf might be set to immutable?
Comment 4 Jeremy Katz 2002-03-07 16:48:22 EST
It's possible ... without the backtrace, it's really difficult to say what
happened :(
Comment 5 Jeremy Katz 2002-03-14 23:49:54 EST
Was this an absolute symlink or a relative symlink (ie was it to
../etc/lilo.conf or /boot/lilo.conf)
Comment 6 Juan Jose Amor 2002-03-15 03:50:19 EST
Yes, if it was a relative symlink, I assume it would work. However,
I did an absolute link, so when anaconda mounts existing partitions under
/mnt, it does not check this issue.

Comment 7 Jeremy Katz 2002-03-18 19:44:42 EST
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.