Bug 580682 - move readlink from /usr/bin to /bin
move readlink from /usr/bin to /bin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 586948
  Show dependency treegraph
 
Reported: 2010-04-08 14:54 EDT by Till Maas
Modified: 2010-05-17 15:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: coreutils-7.6-11.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586948 (view as bug list)
Environment:
Last Closed: 2010-04-15 08:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-04-08 14:54:06 EDT
Description of problem:
/bin/mount.crypt from pam_mount uses readlink. Since it might be called to umount partitions after /usr is umounted, it will fail because it cannot access readlink. Therefore please move readlink from /usr/bin to /bin. It might be a good idea to add a symlink afterwards from /usr/bin/readlink to ../../bin/readlink to avoid problems with hardcoded paths.

Version-Release number of selected component (if applicable):
coreutils-7.6-9.fc12
Comment 1 Ondrej Vasik 2010-04-08 15:38:42 EDT
It makes sense... but symlink will be definitely needed.
Comment 2 Ondrej Vasik 2010-04-15 08:26:01 EDT
Fixed in rawhide and built as coreutils-8.4-8.fc14. Closing NEXTRELEASE, I'll change it in already released Fedora in next cumulative coreutils update.
Comment 3 Fedora Update System 2010-04-28 11:04:39 EDT
coreutils-8.4-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/coreutils-8.4-6.fc13
Comment 4 Fedora Update System 2010-04-28 12:06:18 EDT
coreutils-7.6-11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/coreutils-7.6-11.fc12
Comment 5 Fedora Update System 2010-04-28 14:56:36 EDT
coreutils-7.2-8.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/coreutils-7.2-8.fc11
Comment 6 Fedora Update System 2010-05-04 19:52:40 EDT
coreutils-8.4-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-05-17 15:04:14 EDT
coreutils-7.2-8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-05-17 15:07:20 EDT
coreutils-7.6-11.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.