Bug 58072 - muttypes.h requires <pkgconf/kernel.h>
Summary: muttypes.h requires <pkgconf/kernel.h>
Status: CLOSED NOTABUG
Alias: None
Product: eCos
Classification: Retired
Component: POSIX (EL/IX)   
(Show other bugs)
Version: CVS
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Larmour
QA Contact: eCos bugs internal list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-07 20:24 UTC by Luoqi Chen
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-07 20:24:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luoqi Chen 2002-01-07 20:24:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
<cyg/posix/muttypes.h> depends on <pkgconf/kernel.h>, but doesn't explicitly 
include it. It may result in wrong size for pthread_mutex_t if muttypes.h is 
included before kernel.h.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create C file, starting with
#include <sys/types.h>
#include <pthread.h>
and print out sizeof(pthread_mutex_t)
2.default elix config
3.compile and run, the size printed would be wrong!
	

Additional info:

Comment 1 Jonathan Larmour 2002-01-07 21:23:21 UTC
muttypes.h has included <pkgconf/kernel.h> since 6th November according to the
ChangeLog



Note You need to log in before you can comment on or make changes to this bug.