Bug 5808 - Updateing the kernel with rpm broke my system - reinstall
Updateing the kernel with rpm broke my system - reinstall
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 1999-10-10 13:29 EDT by margarita
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-05 18:46:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description margarita 1999-10-10 13:29:17 EDT
I updated the kernel with the rpms and I could not boot
after that - reinstall. I had used all the kernel rpms.

I tried a second time with just the i586 modules with the
same result.

What did I do wrong?

I am running a amd K6 450mz clocked back to 300mz. I had to
clock back because win95 won't run at more than 300mz
(all but the last release)
Comment 1 Cristian Gafton 2000-01-04 17:26:59 EST
Assigned to dledford
Comment 2 Bill Nottingham 2000-02-05 18:46:59 EST
Did you re-run lilo? If you do an rpm -U upgrade,
you'll need to edit your /etc/lilo.conf to point
it at the new kernel, and re-run lilo.
Comment 3 Bernard DAUTREVAUX 2000-03-27 08:33:59 EST
I don't know if it's related, but I upgraded my stock 6.1 release with the
2.2.14-8smp kernel as provided by Ed Schlunder on
http://www.ajusd.org/~edward/silkhat-6.1/i386/kernel-smp-2.2.14-8.i686.rpm by
using GNORPM in update mode, what seems the natural way to do :-).

I then look at my /etc/lilo.conf and change to redirect to the new kernel and
ramdisk image, then ran lilo and badam! it says that I was missing an ram-disk
image for this kernel version ;-(

So I look at the docs and see that I have to type the following magic

mkinitrd /boot/initrd-2.2.14-8smp.img 2.2.14-8smp

I try it and re-badam! I get the following error (or approximately I've forget
to note it but the meaning is clear):
Comment 4 Bernard DAUTREVAUX 2000-03-27 08:34:59 EST
Excuse me, I've hit 'ALT-C' I think, by error and submitted an incomplete
comment; here is the end:

I get the following error:
Comment 5 Bernard DAUTREVAUX 2000-03-27 08:46:59 EST
No excuse me I've just tried to start a line by a TAB followed by the letter
C!  Quite usual when typing an email message but fatal in Bugzilla... Probably
a small ergonomy problem ;-P

Anyway I promise to be careful now... but back to my problem:

I get the following error:
    Can't acess /dev/loop0: no device driver; maybe "insmod"?

I then looked at the needed modules and then BINGO, the rpm -U has already
deleted my /lib/modules/2.2.12-32smp directory... so I no more can "insmod
loop",, and the one from 2.2.14-8smp obviusly cannot be loaded in my current

Whow, so I had to re-install the stock 6.1 kernel (hopefully I had the CD at
hand), manually load the "loop.o" module, then install the new kernel,
mkinitrd, lilo, and voila... not very convenient indeed ?-)

Isn't it possible that install scripts for the kernel first load all the
modules that may be needed for proper configuration of the system, or better do
NOT remove old kernels till the system has rebooted successfully with the new
one? as all files are tagged with the kernel version number, there is NO
problem in having several kernel versions present at the same time (you can
even choose the version at boot time) and that would avoid a lot of hassles and
provide a backup boot solution if all else fails.

Also the call to mkinitrd should be done by the install script and an entry in
lilo.conf could be automatically added and lilo automatically re-run; that
should be a lot more convenient.

Note You need to log in before you can comment on or make changes to this bug.