This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 580835 - xdg-open does not support LXDE
xdg-open does not support LXDE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xdg-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: LXDE
  Show dependency treegraph
 
Reported: 2010-04-09 04:05 EDT by Martin Tarenskeen
Modified: 2010-11-02 18:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: xdg-utils-1.0.2-21.20101028.fc14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-02 18:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 26058 None None None Never

  None (edit)
Description Martin Tarenskeen 2010-04-09 04:05:48 EDT
Description of problem:
xdg-open does not work with LXDE desktop

Version-Release number of selected component (if applicable):
xdg-utils-1.0.2-16.20091217cvs.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. install and use LXDE desktop
2. run xdg-open foo.png  (replace "foo.png" by any existing picture in your current directory)
3. this is just one of many possible examples.
  
Actual results:
My standard browser opens, which in turn opens my standard picture viewer

Expected results:
My standard picture viewer should start directly, without the help of my webbrowser.

Additional info:
I managed to work around this problem by manually editing the /usr/bin/xdg-open script. But I'm sure you can do better.   
LXDE has become one of the most popular desktops. I think the Fedora-LXDE Live CD spin is number 2 on the list of most popular Fedora Live CD downloads. Therefore xdg should support LXDE out-of-the-box.
Comment 1 Rex Dieter 2010-04-09 15:49:13 EDT
Does lxde provide any utilities for opening files or querying mime-types?

This will likely require work by someone who knows more about lxde than I to impliment.  lemme see who I can poke.
Comment 2 Christoph Wickert 2010-04-09 16:12:47 EDT
(In reply to comment #1)
> Does lxde provide any utilities for opening files or querying mime-types?

Nope. xdg-open should however fall back to the generic handler, but usually mimeopen (from perl-File-MimeInfo) is not installed.

I will look into this and speak with LXDE upstream.
Comment 3 Christoph Wickert 2010-04-09 19:12:24 EDT
Works for me after installing perl-File-MimeInfo. Should we make xdg-utils depend on it?
Comment 4 Christoph Wickert 2010-10-28 15:56:23 EDT
upstream bug report with patches: 
https://bugs.freedesktop.org/show_bug.cgi?id=26058

I spoke to Vincent Untz and it looks like xdg-utils is unmaintained. He agreed that someone from the LXDE community an take it over in the longer run.
Comment 5 Rex Dieter 2010-10-28 16:48:30 EDT
Hint: xdg-utils *is* maintained, and I'm one of it's upstream maintainers.  More help is always welcome. :)

(I've been pushing for a new release, it's been a *very* long time... I guess if I want it, I'll have to not wait for others to do it and help more to make it happen).
Comment 6 Rex Dieter 2010-10-28 16:59:25 EDT
patch upstreamed, included in new rawhide build, xdg-utils-1.0.2-21 , mind trying it out?

I can do updates once we sanity test this a bit.
Comment 7 Christoph Wickert 2010-10-28 17:26:50 EDT
(In reply to comment #5)
> Hint: xdg-utils *is* maintained, and I'm one of it's upstream maintainers. 


Sorry, I didn't want to treat on your toes I just relied on what Vincent told me last week and the last time I looked, the last commit was 3 years ago.

(In reply to comment #6)
> patch upstreamed, included in new rawhide build, xdg-utils-1.0.2-21 , mind
> trying it out?

Thanks for committing the patches, I will test the new package ASAP.
Comment 8 Christoph Wickert 2010-10-28 17:59:30 EDT
Seems to work fine, opening pcmanfm from xdg-open works
Comment 9 Fedora Update System 2010-10-28 20:44:17 EDT
xdg-utils-1.0.2-21.20101028.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xdg-utils-1.0.2-21.20101028.fc14
Comment 10 Fedora Update System 2010-10-29 16:40:44 EDT
xdg-utils-1.0.2-21.20101028.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xdg-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xdg-utils-1.0.2-21.20101028.fc14
Comment 11 Fedora Update System 2010-11-02 18:17:33 EDT
xdg-utils-1.0.2-21.20101028.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.