Bug 5809 - Upgrade 6.0->6.1 fails from ISO image
Upgrade 6.0->6.1 fails from ISO image
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-10 14:46 EDT by blomman
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 15:43:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description blomman 1999-10-10 14:46:50 EDT
Downloaded ISO image from ftp.sunet.se. Seem to be the same
as on ftp.redhat.com site (same date=Sep 27, same md5sum).
Created a boot floppy from the "boot.img" and booted from
it. Everything goes fine until the install of RPMs is
supposed to begin. Nothing happens...

MD5sum of image matches the one in the "md5sums" file.
Verify of the burnt CDROM went ok.

A look at Ctrl-Alt-F1 says (copied by hand):

Gdk-WARNING **: shmget failed!
Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 276, in
__bootstrap
    self.run()
  File
"/mnt/redhat/comps/install/6.1/i386/RedHat/instimage/usr/lib
/python1.5/site-packages/iw/progress.py", line 16, in run
  File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/t
odo.py", line 1512, in doInstall
    prob = "%-15s %d %c\n" % (mount, need, suffix)
TypeError: illegal argument type for built-in operation
Comment 1 Jay Turner 1999-10-11 08:24:59 EDT
This error is the result of not having enough drive space for the
upgrade.  Now, that does not make the error correct, but at least it
tells you why the error appeared.  You might want to check and make
sure that you have enough drive space for the upgrade.  We will try to
determine why this error is occurring.
Comment 2 David Woodhouse 1999-10-14 11:34:59 EDT
I went round in circles about three times deleting stuff from the
filesystem until it no longer complained that it there was not enough
space.

How much disk space (over and above the amount that it _claims_ it
needs) does it _actually_ need?
Comment 3 Jay Turner 1999-10-22 15:34:59 EDT
*** Bug 6024 has been marked as a duplicate of this bug. ***

When installing from a local disk a python scripting error
occurs on a second install attempt if the first install
attempt failed because of a lack of free disk space.

Scenario:

1. Select Packages to install
2. Install Screen determines you need an additional XX MB of
space to proceed.
3. Press <Back> to uncheck some more packages which are not
required
4. Select install and an error occurs because the device is
in use.

Python scripting error and you can select to drop in debug.

---

Work around is to flip to F2 console and manually unmount
the /tmp/hdimage after the installer determined there was
not enough free space to install.

I guess the fix would be to unmount the local disk partition
when it is determined there is not enough space to install.
This should be okay since the only option at this point is
to press <Back>... There are other temporary mounts which
are unmounted automatically... just not the /tmp/hdimage.

The manual unmount worked successful.

If the error occurs... the installer automatically reboots
the machine after shutting everything down.
Comment 4 Jay Turner 1999-10-29 14:37:59 EDT
*** Bug 6402 has been marked as a duplicate of this bug. ***

When upgrading from 6.0 to 6.1, possibly associate with some
kind of mount error, definitely associated with customizing
the list of packages to be installed, I got the following
python traceback from the (very slick) new installer:

Gdk-WARNING **: shmget failed!
Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376 in
__bootstrap (? handwriting is garbled)
    self.run()
  File "/usr/lib/python1.5/site-packages/iw/progress.py",
line 16, in run
    rc = self.todo.doInstall()
  File "/usr/lib/python1.5/site-packages/todo.py", line 1512
in doInstall
    prob = "%-15s %d %c\n" % (mount, need, suffix)
TypeError: illegal argument type for builtin operation

------- Additional Comments From culliton@clark.net  10/26/99 19:28 -------
BTW - This is with the latest boot image from updates.rdehat.com and a
local CD install.

------- Additional Comments From culliton@clark.net  10/26/99 19:46 -------
This may be a duplicate of #5809.  Apologies.  It takes a while to
learn how to search for existing reports, you really have to submit
one yourself to figure it out.

------- Additional Comments From   10/30/99 13:51 -------
Bugzilla item 6348 seems to be related as well.
Comment 5 Jeff Macdonald 1999-11-21 14:24:59 EST
I would agree with the fact that Bugzilla item 6348 is related. Seems that if
there isn't enough disk space on a partition (I have a 10MB /boot), you'll get
this error, even in the recently released updates disk. Bug 6348 points out the
fact that need (from prob-"%-15s %d %c\n" % (mount, need, suffix) is a list (or
is it a tupple?), when it really need to be number. Instead of getting the
message that you don't have enough disk space, you get the exception. In my case
when I used the debugger to print these values I got mount='/boot', need=(25,),
suffix='k'. So from reading the code I deduced that it needed another 25k in
boot to be free, so I simply rebooted to 6.0, removed the SMP stuff and started
an upgrade. All went well.
Comment 6 Jay Turner 1999-12-03 10:27:59 EST
This issue has been assigned to a developer for further action.
Comment 7 Jay Turner 2000-02-11 15:43:59 EST
This issue is resolved in the latest installer (available in beta) and the drive
space estimation has been improved in the new release.

Note You need to log in before you can comment on or make changes to this bug.