Bug 58091 - up2date fails to run
up2date fails to run
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-08 07:30 EST by Reuben Farrelly
Modified: 2015-01-07 18:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 16:08:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2002-01-08 07:30:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
Up2date fails to run, displays an error message and then dies, running the 
latest rawhide 20020107.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type     up2date    or  rhn_register at a bash prompt
2.   error displays ;-)
3.
	

Actual Results:  An error was shown and the python scripts failed to run, 
producing this output:

[root@tornado rpms]# up2date 
/usr/sbin/up2date:537: SyntaxWarning: name 'progressCurrent' is used prior to 
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:537: SyntaxWarning: name 'hashesPrinted' is assigned to 
before global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:537: SyntaxWarning: name 'lastPercent' is assigned to before 
global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:537: SyntaxWarning: name 'progressTotal' is assigned to 
before global declaration
  def rpmCallback(what, amount, total, hdr, path):
/usr/sbin/up2date:537: SyntaxWarning: name 'progressCurrent' is assigned to 
before global declaration
  def rpmCallback(what, amount, total, hdr, path):
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1044, in ?
    main()
  File "/usr/sbin/up2date", line 320, in main
    up2date.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2date.py", line 460, in updateLoginInfo
    loginInfo = login()
  File "/usr/share/rhn/up2date_client/up2date.py", line 362, in login
    server = getServer()
  File "/usr/share/rhn/up2date_client/up2date.py", line 288, in getServer
    password=proxyPassword)
TypeError: __init__() got an unexpected keyword argument 'username'
[root@tornado rpms]#

[root@tornado rpms]# rhn_register
[screen appears, system appears already registered]
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 183, in ?
    main()
  File "/usr/sbin/rhn_register", line 164, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1042, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 986, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 45, in __init__
    tb = snack.Textbox(size[0]-10, size[1]-14, rhnreg.welcomeText(), 1)
  File "/usr/share/rhn/register/rhnreg.py", line 413, in welcomeText
    s = getServer()
  File "/usr/share/rhn/register/rhnreg.py", line 403, in getServer
    password=proxyPassword)
TypeError: __init__() got an unexpected keyword argument 'username'
[root@tornado rpms]# 



Expected Results:  Up2date or rhn_register should have worked

Additional info:

This problem occured once I upgraded the system to python-2.2.

[root@tornado rpms]# rpm -q up2date
up2date-2.7.19-7.x.2
[root@tornado rpms]# rpm -q python
python-2.2-1
[root@tornado rpms]# rpm -q rhn_register
rhn_register-2.7.2-7.x.8
[root@tornado rpms]# rpm -q glibc
glibc-2.2.4-20

[root@tornado rpms]# rpm -qa | grep -i rpm
rpm-build-4.0.4-0.5
rpm-4.0.4-0.5
rpm-python-4.0.4-0.5

Completely removing python/up2date/rhn_register packages and reinstalling them 
made no difference.  I have also rm -rf /etc/sysconfig/rhn/* and they still 
failed to run, giving this same error.
Comment 1 Adrian Likins 2002-01-16 16:08:18 EST
Looks like python2 issues. The version of up2date in rawhide
isnt ported to python2 yet, so it's kind of broken. 

Comment 2 Reuben Farrelly 2002-02-01 21:25:15 EST
Looks to be fixed in the latest release in rawhide up2date-2.7.25-8.x.4 - this 
version works with Python 2.2

Thanks!

Note You need to log in before you can comment on or make changes to this bug.