Bug 580987 - fastestmirror doesn't obey cachedir
fastestmirror doesn't obey cachedir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:ea4b54b5
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-09 13:25 EDT by Pavel Alexeev
Modified: 2014-01-21 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-12 10:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48 bytes, text/plain)
2010-04-09 13:25 EDT, Pavel Alexeev
no flags Details

  None (edit)
Description Pavel Alexeev 2010-04-09 13:25:49 EDT
abrt 1.0.9 detected a crash.

architecture: i686
backtrace: /var/cache/abrt/pyhook-1270669078-6594/backtrace
cmdline: /usr/bin/python /usr/bin/yum clean all
comment: yum clean all as regular user
component: yum
executable: /usr/bin/yum
kernel: 2.6.33-1.fc13.i686
package: yum-3.2.27-2.fc13
release: Fedora release 13 (Goddard)
Comment 1 Pavel Alexeev 2010-04-09 13:25:51 EDT
Created attachment 405591 [details]
File: backtrace
Comment 2 seth vidal 2010-04-09 13:33:07 EDT
Is there anything more to this backtrace? B/c it looks like an ABRT bug at this point.
Comment 3 Pavel Alexeev 2010-04-10 17:05:41 EDT
What I can provide more?
When I run:
yum clean all
as regular user I got this error:
$ LANG=C yum clean all
Loaded plugins: auto-update-debuginfo, changelog, downloadonly, fastestmirror, fs-snapshot, langpacks, post-transaction-actions, presto, refresh-packagekit, remove-with-leaves, rpm-warm-cache,
              : show-leaves, upgrade-helper, verify
Cleaning up Everything
Cleaning up list of fastest mirrors
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 538, in doCommand
    return base.cleanCli(extcmds)
  File "/usr/share/yum-cli/cli.py", line 902, in cleanCli
    self.plugins.run('clean')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 177, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 119, in clean_hook
    os.unlink(hostfilepath)
OSError: [Errno 13] Permission denied: '/var/cache/yum/timedhosts.txt'

It is always reproducible. If this information is not enough, please describe more what I should provide additional.
Comment 4 James Antill 2010-04-12 10:32:57 EDT
this is fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.